Ask Your Question
0

MotorControlMsgs/Stiffness baxter

asked 2017-01-27 10:47:23 -0500

Nemanja gravatar image

updated 2017-01-27 11:01:04 -0500

gvdhoorn gravatar image

I tried viewing the stiffness parameter for the baxter robot, by executing:

rostopic echo /robot/limb/right/stiffness

but this just gives me an error:

ERROR: Cannot load message class for [MotorControlMsgs/Stiffness]. Are your messages built?

I tried searching for this message package, but only thing I'm getting is http://wiki.ros.org/control_msgs which doesn't contain stiffness parameters.

Anyone ever had similar problems or knows how to find MotorControlMsgs?

Thank you

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-27 11:00:19 -0500

gvdhoorn gravatar image

updated 2017-01-27 11:47:35 -0500

Have you setup your Baxter ROS workspace correctly and sourced the setup.bash after catkin_make-ing it?


Edit: from reading How to read /robot/limb/left/command_joint_position? and Collision Detection over at brr-users -- which seeing your posts there you also found -- it would appear that topics carrying messages from the MotorControlMsgs package are not meant to be used by end-users. The MotorControlMsgs package is therefore not available.

edit flag offensive delete link more

Comments

Yes, all other Messages work correctly.

Nemanja gravatar image Nemanja  ( 2017-01-27 11:22:25 -0500 )edit

Yes, I just got the answer. Thanks for the help!

Nemanja gravatar image Nemanja  ( 2017-01-27 12:04:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-27 10:47:23 -0500

Seen: 140 times

Last updated: Jan 27 '17