Ask Your Question
0

Baxter Installation on ROS groovy

asked 2014-09-22 09:49:32 -0500

GoBaxter gravatar image

I am trying to install Baxter on ROS groovy from catkin workspace where the SDK resides, and use wstool to install and update. This is waht i am supposed to do:-

    $ cd ~/ros_ws/src
    $ git clone git@github.com:RethinkRobotics/baxter_simulator.git
# IMPORTANT EARLY-DEV-RELEASE STEPS:
    $ cd baxter_simulator
    $ git checkout early_interface_dev
    $ cd ..
    $ wstool init # need to do this only if this is a new workspace where this command was not executed before.
    $ wstool merge baxter_simulator/baxter_simulator.rosinstall
    $ wstool update

But after i type in <git checkout="" early_interface_dev=""> i get this error message. please explain the reason and solution.

sa@svs-FX6860:~/catkin_ws/src/baxter_simulator$ git checkout early_interface_dev
error: pathspec 'early_interface_dev' did not match any file(s) known to git.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-09-22 11:38:33 -0500

ahendrix gravatar image

updated 2014-09-22 11:38:50 -0500

That error usually means that the branch you're trying to check out doesn't exist.

Since the repository in question doesn't exist or isn't public, you should probably contact Rethink directly for further support.

edit flag offensive delete link more

Comments

I just skipped that error-ridden step and proceeded with other steps and things worked out. I have not yet rationalised why it should be so. Still things worked out!

GoBaxter gravatar image GoBaxter  ( 2015-02-02 17:16:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-22 09:49:32 -0500

Seen: 113 times

Last updated: Sep 22 '14