Ask Your Question
2

Unable to locate package ros-indigo-moveit-full

asked 2017-01-03 01:30:25 -0600

Lileping gravatar image

I want to use ros-planning/moveit pkg.Because it includes moveit_kinematics.But After I run "sudo apt-get remove ros-indigo-moveit-full",I can't use moveit.When I run "sudo apt-get install ros-indigo-moveit-full" again,It appeared "Unable to locate package ros-indigo-moveit-full" .

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-01-03 03:30:48 -0600

130s gravatar image

updated 2017-01-05 16:06:30 -0600

Indeed the installation tutorial for MoveIt! Indigo is outdated. Thank you for catching that.

ros-indigo-moveit-full was recently removed for all ROS Indigo/Jade/Kinetic. From the next release of Indigo, which is planned soon, you'll be able to install ros-indigo-moveit that includes moveit_kinematics.

If you're really in hurry so that you can't wait for another few days, you can already install them from Shadow Repository.


UPDATE: Opened a PR to update the installation tutorial.


UPDATE 20170105 MoveIt! maintainers realized that removing ros-indigo-moveit-full broke existing usecases. So it's released back again and will become available on shadow repo soon and on official public repo at the next public sync (the one that was like this announcement).

edit flag offensive delete link more

Comments

Thanks a lot.I will wait for it. I am hurry to use moveit to control real UR5.The universal robot pkg needs moveit_kinematics.

Lileping gravatar imageLileping ( 2017-01-03 06:52:55 -0600 )edit
1

Currently I can't run sudo apt-get install ros-indigo-moveit nor sudo apt-get install ros-indigo-moveit-full. I tested it on multiple mashines. Is this still a problem with the official public repo or is it something on my side?

F4bich gravatar imageF4bich ( 2017-01-25 08:43:04 -0600 )edit

Looking at the package status on buildfarm, moveit seems released without issues. moveit_full will become available on the next public release (watch this thread or similar).

130s gravatar image130s ( 2017-01-28 09:20:15 -0600 )edit

@F4bich, I have the same problem. sudo apt-get install ros-indigo-moveit is not being located.

bhavyadoshi26 gravatar imagebhavyadoshi26 ( 2017-01-29 11:12:27 -0600 )edit

@F4bich@bhavyadoshi26 I've opened a ticket for discussing the issue more. Please consider providing more info there.

130s gravatar image130s ( 2017-01-29 22:33:51 -0600 )edit
1

answered 2017-01-03 01:37:30 -0600

gijsje170 gravatar image

Did you setup your sources list correctly? Is it only the ros-indigo-moveit-full package or also other ros-indigo packages. Did you try to when getting sources again? http://wiki.ros.org/indigo/Installati...

edit flag offensive delete link more

Comments

Thanks a lot .I haved tried sourced again. In ~/.bashrc file,the last line is "source /opt/ros/indigo/setup.bash". But I still can't use move_group.launch .and "sudo apt-get install ros-indigo-moveit-full", Unable to locate package ros-indigo-moveit-full.

Lileping gravatar imageLileping ( 2017-01-03 02:52:50 -0600 )edit

Did you also update rosdep and what does your pc find when you "sudo apt-get install ros-indigo-" tab tab?

gijsje170 gravatar imagegijsje170 ( 2017-01-03 03:14:41 -0600 )edit

I have done "rosdep update and sudo apt-get update".as said here. And created an workspace named "ws_moveit".Then I can use move_group.launch But when I run a moveit_ik demo,it said "AttributeError: 'module' object has no attribute 'MoveGroupInterface'".

Lileping gravatar imageLileping ( 2017-01-03 04:38:27 -0600 )edit

When I run "sudo apt-get install ros-indigo-moveit-"tab tab ,It didn't show ros-indigo-moveit-full, just appeared ros-indigo-moveit and others

Lileping gravatar imageLileping ( 2017-01-03 04:43:04 -0600 )edit

It's probably what 130s is saying

gijsje170 gravatar imagegijsje170 ( 2017-01-03 06:01:06 -0600 )edit

I agree with you

Lileping gravatar imageLileping ( 2017-01-03 06:53:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2017-01-03 01:30:25 -0600

Seen: 2,714 times

Last updated: Jan 05 '17