ROS_Control: Controller doesn't get loaded

asked 2016-11-25 16:31:23 -0500

nikku gravatar image

updated 2016-11-26 05:40:24 -0500

gvdhoorn gravatar image

Hi there.

I'm using ROS Indigo and Gazebo2 I'm trying to implement a controller for my revolute joint in Gazebo. For that I looked how the controlling problem was solved with the rrbot or the mybot.

However, when I try to start my controllers using a roslaunch file:

<launch>
  <!-- Load joint controller configurations from YAML file to parameter server -->
  <rosparam file="$(find erod_control)/config/erod_control.yaml" command="load"/>

  <!-- load the controllers -->
  <node name="controller_spawner" pkg="controller_manager" type="spawner" respawn="false" output="screen" ns="/erod" args="joint_state_controller linksController rechtsController"  />

  <!-- convert joint states to TF transforms for rviz, etc -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" respawn="false"  output="screen">
    <param name="robot_description" command="$(find xacro)/xacro.py '$(find erod_description)/urdf/erod.xacro'" />
    <remap from="/joint_states" to="/erod/joint_states" />
  </node>
</launch>

I get the following error message:

[ERROR] [WallTime: 1480112626.683817] [0.000000] Failed to load linksController
[ERROR] [WallTime: 1480112627.691181] [0.000000] Failed to load rechtsController

As well as

[ERROR] [1480112625.682869242]: Could not load controller 'linksController' because the type was not specified. Did you load the controller configuration on the parameter server (namespace: '/erod/linksController')?

The whole procedure worked perfectly for rrbot and for the mybot but somehow it won't work for my new robot.

Thanks for your help

EDIT: My controller yaml file looks like this

erod:
  # Publish all joint states -----------------------------------
  joint_state_controller:
    type: joint_state_controller/JointStateController
    publish_rate: 50

  # Effort Controllers ---------------------------------------
 linksController:
   type: effort_controllers/JointEffortController
   joint: front_left_bar_joint
   pid: {p: 100.0, i: 0.1, d: 10.0}
 rechtsController:
   type: effort_controllers/JointEffortController
   joint: front_right_bar_joint
   pid: {p: 100.0, i: 0.1, d: 10.0}
edit retag flag offensive close merge delete

Comments

I think we're going to need the contents of config/erod_control.yaml. Could you edit that into your question?

gvdhoorn gravatar imagegvdhoorn ( 2016-11-26 02:18:27 -0500 )edit

I added the yaml file

nikku gravatar imagenikku ( 2016-11-26 05:38:50 -0500 )edit

I'm having the same issue, and I have all the controllers packages installed, did you find out what the problem was?

Miriam gravatar imageMiriam ( 2018-05-22 10:57:43 -0500 )edit

hi, i got the same issue, did you guys find out how to solve the problem? thx

myrotrac gravatar imagemyrotrac ( 2019-01-21 09:50:18 -0500 )edit