ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

RVIZ crashes when I add Camera/ Image Type

asked 2016-11-12 01:21:11 -0600

Naman gravatar image

updated 2016-11-14 11:15:48 -0600

Hi all,

I installed ROS Indigo in Ubuntu 14.04 and the RVIZ version is 1.11.15. When I run rviz and try to add Image or Camera display type, RVIZ crashes giving following output:

Segmentation Fault (Core Dumped)

Although I am able to add PointCloud2 display type without any issues.
I have NVIDIA drivers version 367.27.

Update - 1
I get the following output after building RVIZ from source and running with GDB. The segmentation fault occurs when I try to add the Camera display type to RVIZ:

c-naman.kumar@namanviumar:~$ rosrun --prefix 'gdb --args' rviz rviz
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /home/likewise-open/FARADAYFUTURE/c-naman.kumar/catkin_ws/devel/lib/rviz/rviz...done.
(gdb) run
Starting program: /home/likewise-open/FARADAYFUTURE/c-naman.kumar/catkin_ws/devel/lib/rviz/rviz 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7fffdbd6a700 (LWP 8788)]
[New Thread 0x7fffdb569700 (LWP 8789)]
[New Thread 0x7fffd3fff700 (LWP 8790)]
[New Thread 0x7fffd37fe700 (LWP 8791)]
[New Thread 0x7fffd2ffd700 (LWP 8792)]
[ INFO] [1479141998.084372668]: rviz version 1.11.15
[ INFO] [1479141998.084458500]: compiled against Qt version 4.8.6
[ INFO] [1479141998.084484005]: compiled against OGRE version 1.8.1 (Byatis)
[New Thread 0x7fffd25f1700 (LWP 8796)]
[New Thread 0x7fffd1df0700 (LWP 8797)]
[New Thread 0x7fffd15ef700 (LWP 8798)]
[New Thread 0x7fffd0dee700 (LWP 8803)]
[Thread 0x7fffd37fe700 (LWP 8791) exited]
[New Thread 0x7fffd37fe700 (LWP 8804)]
[New Thread 0x7fffadae8700 (LWP 8805)]
[New Thread 0x7fffad2e7700 (LWP 8806)]
[New Thread 0x7fffacae6700 (LWP 8807)]
[New Thread 0x7fffa7fff700 (LWP 8808)]
[New Thread 0x7fffa77fe700 (LWP 8809)]
[New Thread 0x7fffa6ffd700 (LWP 8810)]
[New Thread 0x7fffa67fc700 (LWP 8811)]
[New Thread 0x7fffa5ffb700 (LWP 8812)]
[New Thread 0x7fffa57fa700 (LWP 8813)]
[New Thread 0x7fffa4ff9700 (LWP 8814)]
[New Thread 0x7fff83fff700 (LWP 8815)]
[ INFO] [1479141998.795922717]: Stereo is NOT SUPPORTED
[ INFO] [1479141998.796146340]: OpenGl version: 4.5 (GLSL 4.5).
[New Thread 0x7fff837fe700 (LWP 8829)]
[New Thread 0x7fff82ffd700 (LWP 8830)]

Program received signal SIGSEGV, Segmentation fault.
__strcmp_sse2_unaligned () at ../sysdeps/x86_64/multiarch/strcmp-sse2-unaligned.S:29
29  ../sysdeps/x86_64/multiarch/strcmp-sse2-unaligned.S: No such file or directory.

Update - 2
Here is the backtrace:

(gdb) bt
#0  __strcmp_sse2_unaligned () at ../sysdeps/x86_64/multiarch/strcmp-sse2-unaligned.S:29
#1  0x00007fff67eae09e in QMetaType::registerNormalizedType(QByteArray const&, void (*)(void*), void* (*)(void const*), void (*)(void*), void* (*)(void*, void const*), int, QFlags<QMetaType::TypeFlag>, QMetaObject const*) () from /usr/lib/x86_64-linux-gnu/ ...
edit retag flag offensive close merge delete



Probably the easiest way to diagnose this is to build RViz from sources with -DCMAKE_BUILD_TYPE=Debug and then run it in GDB. Without a backtrace we'd need a lucky guess to resolve your problem.

gvdhoorn gravatar image gvdhoorn  ( 2016-11-12 06:58:49 -0600 )edit

Thanks. I have updated the question with the output!

Naman gravatar image Naman  ( 2016-11-14 10:49:51 -0600 )edit

Thanks, that's going in the right direction. Could you trigger the SEGFAULT once more, and now, at the gdb prompt, enter bt. Then press enter. Then add the backtrace to your question description.

gvdhoorn gravatar image gvdhoorn  ( 2016-11-14 10:57:16 -0600 )edit

Hey, added the backtrace!

Naman gravatar image Naman  ( 2016-11-14 11:16:17 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-11-15 12:57:11 -0600

Naman gravatar image

The problem was that RVIZ was compiled against Qt4 whereas when I try to load an image/ camera/ depthcloud in RVIZ, it finds Qt5 which was present because I installed opencv 2.4.10 whereas ROS comes with opencv 2.4.8. So, there was a qt conflict because of multiple versions of opencv. I uninstalled opencv 2.4.10 and then also uninstalled ROS with all its dependencies to do a clean install. After installing ROS again, it worked. Hope it helps!

edit flag offensive delete link more

answered 2016-11-13 08:39:15 -0600

Henrique gravatar image

Have you checked if the image topic is ok? You could use rqt_image. also you should verify other transport methods, I know image_raw work.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-11-12 01:21:11 -0600

Seen: 1,082 times

Last updated: Nov 15 '16