Roslaunch not remotely starting master

asked 2016-11-03 08:42:59 -0600

updated 2016-11-03 10:43:10 -0600

Hello,

I have run into an odd little problem. I am using a UAV with an on-board computer running ROS and a separate base station computer. I've done the network setup and the two computers are communicating properly. I'm using roslaunch files with machine tags to control which computer individual nodes start on. This works fine except for one thing. The terminal tells me that it cannot connect to master unless I go into the UAV computer and run roscore first. I find this odd as generally one does not need to run roscore on its own when using a launch file. Has anyone else run into this or know what's causing it?

Thanks

[EDIT]
I don't have ROS_IP set on either of them. What I do have is export ROS_MASTER_URI=http://UAVSartrex:11311 in the .bashrc of both the base station and uav computers.

edit retag flag offensive close merge delete

Comments

Can you post what your ROS_IP and ROS_URI_MASTER are for each. It sounds like your ROS_IP is correct and the ROS_URI_MASTER might be incorrect.

shoemakerlevy9 gravatar imageshoemakerlevy9 ( 2016-11-03 10:18:46 -0600 )edit