Ask Your Question
0

roscore error

asked 2013-02-04 16:14:00 -0600

AdrianPeng gravatar image

updated 2013-02-05 14:27:34 -0600

Hi,

I installed ROS onto Gumstix Overo and roscore command works before. But after I tried to download some ROS packages (though I didn't succeed), I found roscore does't work anymore.

This is the error message:

root@linaro-alip:~# roscore
WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://linaro-alip:46926/
ros_comm version 1.9.41

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion

NODES

auto-starting new master
process[master]: started with pid [1170]
Traceback (most recent call last):
  File "/root/ros_core_ws/install/bin/rosmaster", line 35, in <module>
    rosmaster.rosmaster_main()
  File "/root/ros_core_ws/install/lib/python2.7/dist-    packages/rosmaster/main.py", line 73, in rosmaster_main
    configure_logging()   
  File "/root/ros_core_ws/install/lib/python2.7/dist- packages/rosmaster/main.py", line 57, in configure_logging
    _log_filename = rosgraph.roslogging.configure_logging('rosmaster', logging.DEBUG, filename=filename)
  File "/root/ros_core_ws/install/lib/python2.7/dist-packages/rosgraph/roslogging.py", line 104, in configure_logging
    logging.config.fileConfig(config_file, disable_existing_loggers=False)
  File "/usr/lib/python2.7/logging/config.py", line 78, in fileConfig
    handlers = _install_handlers(cp, formatters)
  File "/usr/lib/python2.7/logging/config.py", line 153, in   _install_handlers
    klass = _resolve(klass)
  File "/usr/lib/python2.7/logging/config.py", line 94, in _resolve
    __import__(used)
ImportError: No module named RosStreamHandler
[master] process has died [pid 1170, exit code 1, cmd rosmaster --core -p  11311 __log:=/root/.ros/log/ba8ca0d2-6f47-11e2-91a2-0015c928fd79/master.log].
log file: /root/.ros/log/ba8ca0d2-6f47-11e2-91a2-0015c928fd79/master*.log
ERROR: could not contact master [http://linaro-alip:11311/]
[master] killing on exit

This is the output of roswtf:

root@linaro-alip:~# roswtf
No package or stack in context
    ================================================================================
Static checks summary:

Found 3 error(s).

ERROR Not all paths in ROS_PACKAGE_PATH[/root/catkin_ws/src:/root/ros_core_ws/install/share:/root/ros_core_ws/install/stacks] point to an existing directory: 
 * /root/ros_core_ws/install/stacks

ERROR Not all paths in PYTHONPATH [/root/catkin_ws/devel/lib/python2.7/dist-packages:/root/ros_core_ws/install/lib/python2.7/dist-packages] point to a   directory: 
 * /root/catkin_ws/devel/lib/python2.7/dist-packages

ERROR ROS_TEST_RESULTS_DIR is invalid: ROS_TEST_RESULTS_DIR[/root/catkin_ws/build/test_results] is not writable
================================================================================

ROS Master does not appear to be running.
Online graph checks will not be run.
ROS_MASTER_URI is [http://localhost:11311]

This is environment variables output:

root@linaro-alip:~# echo $PYTHONPATH
/root/catkin_ws/devel/lib/python2.7/dist-packages:/root/ros_core_ws/install/lib/python2.7/dist-packages

root@linaro-alip:~# echo $ROS_ROOT 
/root/ros_core_ws/install/share/ros

root@linaro-alip:~# echo $ROS_MASTER_URI 
http://localhost:11311

root@linaro-alip:~# echo $ROS_PACKAGE_PATH
/root/catkin_ws/src:/root/ros_core_ws/install/share:/root/ros_core_ws/install/stacks

Anyone can help me? Thanks in advance!!!

edit retag flag offensive close merge delete

Comments

1

It's likely you lost your environment when you were doing other things such that the libraries are not in your PYTHON_PATH. Can you update your question to include your environment variables?

tfoote gravatar imagetfoote ( 2013-02-04 17:07:01 -0600 )edit

Hi tfoote, I updated my question with environment variables output, could you please have a look? Thanks!

AdrianPeng gravatar imageAdrianPeng ( 2013-02-05 14:24:47 -0600 )edit

Ok, when I delete "source /root/catkin_ws/devel/setup.bash" in .bashrc , roscore works. Maybe I have done something wrong with catkin_ws. Anyway, when I recreate catkin_ws and source it in .bashrc, it works.

AdrianPeng gravatar imageAdrianPeng ( 2013-02-05 14:45:14 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-05 14:46:43 -0600

AdrianPeng gravatar image

I solve this problem just by deleting "source /root/catkin_ws/devel/setup.bash" in .bashrc and recreate a catkin work space.

edit flag offensive delete link more
0

answered 2017-02-04 14:16:40 -0600

venkisagunner gravatar image

$ export ROS_HOSTNAME=localhost $ export ROS_MASTER_URI=http://localhost:11311

This should work. Links posted below.

Read the roscore section in, http://wiki.ros.org/ROS/Tutorials/Und...

Read Single machine configuration in, http://wiki.ros.org/ROS/NetworkSetup#...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-04 16:14:00 -0600

Seen: 7,869 times

Last updated: Feb 05 '13