Ask Your Question
0

Can't connect Velodyne VLP-16 to ROS on ubuntu.

asked 2016-10-19 06:39:28 -0600

Mortivor gravatar image

Hi. I tryed to connect VLP-16 to ros on Ubuntu. I have my ubuntu on virtual machine. Version of ros I use is "Indigo".

I built velodyne_driver from source and then was guided by this tutorial.

In tutorial there is this first steps:

Power the LIDAR via the included adapter Connect the LIDAR to an Ethernet port on your computer. Statically assign an IP to this port in the 192.168.3.x range.

sudo ifconfig eth0 192.168.3.100

Add a static route to the LIDAR's IP address. The IP address can be found on the CD case which was included with the LIDAR.

sudo route add 192.168.XX.YY eth0

And i can't realy understand what XX and YY should be? I don't have any CD included. And how could I know are my ip settings set correctly (look any data on my laptop recived by VLP-16)?

One person gave me an advise. It was:

As far as I know the standard address of the VLP-16 is 192.168.1.201. So what I'd do is:

sudo ifconfig eth0 up

sudo ip addr add 192.168.1.200 dev eth0

sudo route add -net 192.168.1.0 netmask 255.255.255.0 dev eth0

Afterwards you should have access to the vlps webinterface via your browser. Then run the vlp driver, and make sure the rpms set in driver and webinterface match.

I did all as he recommend. After that I tryed to enter in my browser 192.168.1.200 or 192.168.1.201 and it said that it "Unable to connect".

Maybe anyone else have any other suggestions. Thanks.

edit retag flag offensive close merge delete

Comments

I would suggest trying it without using a virtual machine. If that works, then it's clear where the problem lies.

joq gravatar imagejoq ( 2016-10-19 14:58:53 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-10-19 23:11:32 -0600

asimay_y gravatar image

updated 2016-10-19 23:13:39 -0600

  1. you can try bridged mode for your virtual machine, or set : copy physical setting to virtual machine,
  2. after setting and connecting ok, disconnect your local network, and then re-active, leave your virtual alive. your local network setting sometimes will impact the vm setting. I'm sure it's your setting env problem, because I'm using well through vm.
edit flag offensive delete link more
0

answered 2016-10-19 17:58:44 -0600

kmhallen gravatar image

If using VMware, make sure the Network Adapter type is set to 'Bridged'. I believe the default is 'NAT', which isolates the VM from the host network.

edit flag offensive delete link more
0

answered 2017-03-22 17:33:45 -0600

Looking to purchase a Velodyne VLP 16 puck? Willing to pay a premium. Does anyone have any leads?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-10-19 06:39:28 -0600

Seen: 1,565 times

Last updated: Oct 19 '16