Ask Your Question
0

catkin_prepare_release not bumping packages in a certain folder?

asked 2016-10-19 01:13:13 -0500

130s gravatar image

Trying to make an initial release for Kinetic from a repository, then only the packages under moveit_plugins don't get bumped. All packages in the repository, regardless they're listed to be released (in the metapkg moveit/package.xml), are aligned to the same version 0.9.0.

What's wrong?

$ git clone https://github.com/ros-planning/moveit.git && cd moveit
$ git checkout 90a62bfd59da94ae3621f516494081fca825721c
$ catkin_prepare_release
Prepare the source repository for a release.
Repository type: git
Found packages: moveit_ros_planning, moveit_core, moveit_planners, moveit_kinematics, moveit_setup_assistant, moveit_commander, moveit_ros_visualization, chomp_motion_planner, chomp_interface, moveit_ros, moveit_ros_perception, moveit_ros_move_group, moveit_experimental, moveit_ros_manipulation, moveit_planners_ompl, moveit_ros_robot_interaction, moveit
Prepare release of version '0.9.1' [Y/n]?
<string>:563: (ERROR/3) Unknown target name: "moveit".
<string>:563: (ERROR/3) Unknown target name: "moveit".
<string>:77: (ERROR/3) Unknown target name: "displaying_trajectory_message".
<string>:95: (ERROR/3) Unknown target name: "animating_path".
<string>:95: (ERROR/3) Unknown target name: "displaying_trajectory_message".
<string>:77: (ERROR/3) Unknown target name: "displaying_trajectory_message".
<string>:95: (ERROR/3) Unknown target name: "animating_path".
<string>:95: (ERROR/3) Unknown target name: "displaying_trajectory_message".
<string>:41: (WARNING/2) Inline emphasis start-string without end-string.
<string>:41: (WARNING/2) Inline emphasis start-string without end-string.
<string>:41: (WARNING/2) Inline emphasis start-string without end-string.
<string>:41: (WARNING/2) Inline emphasis start-string without end-string.
<string>:21: (ERROR/3) Unknown target name: "ptc".
<string>:21: (ERROR/3) Unknown target name: "ptc".
Warning: the following packages do not have a changelog file or entry for version '0.9.1': chomp_interface, chomp_motion_planner, moveit, moveit_commander, moveit_core, moveit_experimental, moveit_kinematics, moveit_planners, moveit_planners_ompl, moveit_ros, moveit_ros_manipulation, moveit_ros_move_group, moveit_ros_perception, moveit_ros_planning, moveit_ros_robot_interaction, moveit_ros_visualization, moveit_setup_assistant
Continue without changelogs [y/N]?y
Trying to push to remote repository (dry run)...
Everything up-to-date
Checking if working copy is clean (no staged changes, no modified files, no untracked files)...
?? moveit_experimental/CHANGELOG.rst
?? moveit_kinematics/CHANGELOG.rst
?? moveit_planners/chomp/chomp_interface/CHANGELOG.rst
?? moveit_planners/chomp/chomp_motion_planner/CHANGELOG.rst
?? moveit_ros/perception/depth_image_octomap_updater/include/moveit/depth_image_octomap_updater/lazy_free_space_updater.h
?? moveit_ros/perception/depth_image_octomap_updater/src/lazy_free_space_updater.cpp
?? moveit_ros/visualization/conf.py
?? moveit_ros/visualization/doc/joystick.rst
?? moveit_ros/visualization/doc/moveit-theme/static/moveit_styles.css
?? moveit_ros/visualization/doc/moveit-theme/theme.conf
?? moveit_ros/visualization/doc/rviz_plugin_collision.png
?? moveit_ros/visualization/doc/rviz_plugin_collision_aware_ik_checkbox.png
?? moveit_ros/visualization/doc/rviz_plugin_interact.png
?? moveit_ros/visualization/doc/rviz_plugin_invalid.png
?? moveit_ros/visualization/doc/rviz_plugin_motion_planning_add.png
?? moveit_ros/visualization/doc/rviz_plugin_planned_path.png
?? moveit_ros/visualization/doc/rviz_plugin_start.png
?? moveit_ros/visualization/doc/rviz_plugin_visualize_robots.png
?? moveit_ros/visualization/doc/tutorial.rst
?? moveit_ros/visualization/python/moveit_ros_visualization/__init__.py
?? moveit_ros/visualization/python/moveit_ros_visualization/moveit_joy.py
?? moveit_ros/visualization/rosdoc.yaml
?? replace_infile.py
Warning: the working copy contains other changes. Consider reverting/committing/stashing them before preparing a release.
Continue anyway [y/N]?y
Rename the forthcoming section of the following packages to version '0.9.1':
Bump version of all packages from '0.9.0' to '0.9.1'
Committing the package.xml files...
[kinetic-devel 90a62bf] 0.9.1
 17 files changed, 17 insertions(+), 17 deletions(-)
Creating tag '0.9.1'...
The following commands will be executed to push the changes and tag to the remote repository:
  /usr/bin/git push origin kinetic-devel
  /usr/bin/git push --tags
Execute commands to push the ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-19 10:16:09 -0500

Dirk Thomas gravatar image

If I run your commands as stated I get the following output / error:

Prepare the source repository for a release.
Repository type: git
Found packages: moveit_controller_manager_example, moveit_ros_control_interface, moveit_fake_controller_manager, moveit_ros_perception, moveit_experimental, moveit_ros_move_group, moveit_setup_assistant, moveit_plugins, moveit_ros_benchmarks, moveit_ros_warehouse, moveit_kinematics, moveit_commander, moveit_ros_visualization, moveit_ros_planning_interface, moveit_ros_robot_interaction, moveit_ros_planning, moveit_core, moveit_planners, moveit_ros_manipulation, chomp_motion_planner, moveit_ros, moveit_simple_controller_manager, moveit_planners_ompl, chomp_interface, moveit
Two packages have different version numbers (0.9.1 != 0.9.0):
- ./moveit_ros/perception/package.xml
- ./moveit_plugins/moveit_controller_manager_example/package.xml

And those two packages actually have different version numbers ( https://github.com/ros-planning/movei... vs. https://github.com/ros-planning/movei... ) as the error message indicates.

If I run the command on the latest commit on the kinetic-devel branch (e3ef9a64fe003a8a607f16fd9df112bc7a7d98bf) it seems to update all packages as expected:

  • moveit/package.xml
  • moveit/package.xml
  • moveit_commander/package.xml
  • moveit_core/package.xml
  • moveit_experimental/package.xml
  • moveit_kinematics/package.xml
  • moveit_planners/chomp/chomp_interface/package.xml
  • moveit_planners/chomp/chomp_motion_planner/package.xml
  • moveit_planners/moveit_planners/package.xml
  • moveit_planners/ompl/package.xml
  • moveit_plugins/moveit_controller_manager_example/package.xml
  • moveit_plugins/moveit_fake_controller_manager/package.xml
  • moveit_plugins/moveit_plugins/package.xml
  • moveit_plugins/moveit_ros_control_interface/package.xml
  • moveit_plugins/moveit_simple_controller_manager/package.xml
  • moveit_ros/benchmarks/package.xml
  • moveit_ros/manipulation/package.xml
  • moveit_ros/move_group/package.xml
  • moveit_ros/moveit_ros/package.xml
  • moveit_ros/perception/package.xml
  • moveit_ros/planning/package.xml
  • moveit_ros/planning_interface/package.xml
  • moveit_ros/robot_interaction/package.xml
  • moveit_ros/visualization/package.xml
  • moveit_ros/warehouse/package.xml
  • moveit_setup_assistant/package.xml
edit flag offensive delete link more

Comments

The same issue kept happening at least for 3 times with the same local git repo of mine, but today I cloned the same repo and tested against the forked remote, then the issue didn't happen. So something with my local repo I mainly use is causing.

130s gravatar image130s ( 2016-11-17 00:07:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-10-19 01:13:13 -0500

Seen: 69 times

Last updated: Oct 19 '16