Ask Your Question
0

Error Pre-Release Melodic

asked 2020-03-19 07:21:30 -0500

pietrocolombo gravatar image

Hi, when I do the melodic prerelease procedureI get an error.

It also happens when I do the procedure on versions that in the past were successful

i do this:

mkdir -p /tmp/prerelease_job
cd /tmp/prerelease_job 

generate_prerelease_script.py   https://raw.githubusercontent.com/ros-infrastructure/ros_buildfarm_config/production/index.yaml   melodic default ubuntu bionic amd64   --custom-repo     ira_laser_tools:git:https://github.com/iralabdisco/ira_laser_tools-release.git:release/melodic/ira_laser_tools/1.0.4-1   --level` 1   --output-dir ./

./prerelease.sh

But now i recive this error:

The packages or cmake arguments have changed, forcing cmake invocation

==> Processing catkin package: 'ira_laser_tools'
==> Creating build directory: 'build_isolated/ira_laser_tools'
==> cmake /tmp/ws/src/ira_laser_tools -DCATKIN_DEVEL_PREFIX=/tmp/ws/devel_isolated/ira_laser_tools -DCMAKE_INSTALL_PREFIX=/tmp/ws/install_isolated -DBUILD_TESTING=0 -DCATKIN_SKIP_TESTING=1 -G Unix Makefiles in '/tmp/ws/build_isolated/ira_laser_tools'
-- The C compiler identification is GNU 7.5.0
-- The CXX compiler identification is GNU 7.5.0
-- Check for working C compiler: /usr/lib/ccache/cc
-- Check for working C compiler: /usr/lib/ccache/cc -- broken
CMake Error at /usr/share/cmake-3.10/Modules/CMakeTestCCompiler.cmake:52 (message):
  The C compiler

    "/usr/lib/ccache/cc"

  is not able to compile a simple test program.

  It fails with the following output:

    Change Dir: /tmp/ws/build_isolated/ira_laser_tools/CMakeFiles/CMakeTmp

    Run Build Command:"/usr/bin/make" "cmTC_61b2a/fast"
    /usr/bin/make -f CMakeFiles/cmTC_61b2a.dir/build.make CMakeFiles/cmTC_61b2a.dir/build
    make[1]: Entering directory '/tmp/ws/build_isolated/ira_laser_tools/CMakeFiles/CMakeTmp'
    Building C object CMakeFiles/cmTC_61b2a.dir/testCCompiler.c.o
    /usr/lib/ccache/cc    -o CMakeFiles/cmTC_61b2a.dir/testCCompiler.c.o   -c /tmp/ws/build_isolated/ira_laser_tools/CMakeFiles/CMakeTmp/testCCompiler.c
    ccache: error: Failed to create directory /home/buildfarm/.ccache/tmp: Permission denied
    CMakeFiles/cmTC_61b2a.dir/build.make:65: recipe for target 'CMakeFiles/cmTC_61b2a.dir/testCCompiler.c.o' failed
    make[1]: *** [CMakeFiles/cmTC_61b2a.dir/testCCompiler.c.o] Error 1
    make[1]: Leaving directory '/tmp/ws/build_isolated/ira_laser_tools/CMakeFiles/CMakeTmp'
    Makefile:126: recipe for target 'cmTC_61b2a/fast' failed
    make: *** [cmTC_61b2a/fast] Error 2




  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:2 (project)


-- Configuring incomplete, errors occurred!
See also "/tmp/ws/build_isolated/ira_laser_tools/CMakeFiles/CMakeOutput.log".
See also "/tmp/ws/build_isolated/ira_laser_tools/CMakeFiles/CMakeError.log".
<== Failed to process package 'ira_laser_tools':
  Command '['cmake', '/tmp/ws/src/ira_laser_tools', '-DCATKIN_DEVEL_PREFIX=/tmp/ws/devel_isolated/ira_laser_tools', '-DCMAKE_INSTALL_PREFIX=/tmp/ws/install_isolated', '-DBUILD_TESTING=0', '-DCATKIN_SKIP_TESTING=1', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /tmp/ws/build_isolated/ira_laser_tools && cmake /tmp/ws/src/ira_laser_tools -DCATKIN_DEVEL_PREFIX=/tmp/ws/devel_isolated/ira_laser_tools -DCMAKE_INSTALL_PREFIX=/tmp/ws/install_isolated -DBUILD_TESTING=0 -DCATKIN_SKIP_TESTING=1 -G
'Unix Makefiles'

Command failed, exiting.
# END SUBSECTION
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-03-25 14:02:18 -0500

dpkoch gravatar image

I was struggling with a similar failure, and found this issue that seems related: https://github.com/ros-infrastructure....

It looks like this should have been fixed by https://github.com/ros-infrastructure..., but there hasn't been a new release in a while so maybe those changes haven't landed yet?

It seems like a workaround for now is to create the ~/.ccache directory before running the prerelease script. Or if, as was the case for me, that directory was already created but owned by root, change the ownership to your user (e.g. chown $USER:$USER ~/.ccache). That fixed it for me.

Hope that helps.

edit flag offensive delete link more

Comments

thanks changing permissions it works

pietrocolombo gravatar image pietrocolombo  ( 2020-03-26 05:27:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-03-19 07:21:30 -0500

Seen: 15 times

Last updated: Mar 25