Ask Your Question
0

Frustrating Errors in Loading Motion Planning Library

asked 2016-10-15 00:08:14 -0500

I am facing very unusual problems. I have been using ROS-Indigo under Ubuntu 14.04 on my Virtual Machine and ROS-Indgio under Ubuntu 14.04 on my laptop. Surprisingly, I am seeing totally different kinds of errors on all of these machines while I am using the same tutorials.

Coming to the point, I am trying to run PR2 moveit tutorials given here. On my laptop, I am seeing the following error

PluginlibFactory: The plugin for class 'moveit_rviz_plugin/MotionPlanning' failed to load.  Error: According to the loaded plugin descriptions the class moveit_rviz_plugin/MotionPlanning with base class type rviz::Display does not exist.

and the following error

Exception while loading planner 'ompl_interface/OMPLPlanner': According to the loaded plugin descriptions the class ompl_interface/OMPLPlanner with base class type planning_interface::PlannerManager does not exist.

It is really very frustrating. So, I tried to run it on my virtual machine as well. Please help me, how can I handle this. I have been spending a lot of time on it and it is not working.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-10-15 06:09:29 -0500

gvdhoorn gravatar image

updated 2016-10-16 06:21:16 -0500

Both of these errors point to missing packages. Do you have the ros-<distro>-moveit-ros-visualization and the ros-<distro>-moveit-planners-ompl packages installed?

Similar Q/A: moveit rviz plugin error.

edit flag offensive delete link more

Comments

Thank you so gvdhoorn. It is working now. I am so grateful to you for your comment. I spent almost 2 days in figuring out what's the problem and tried to install as many packages to resolve this but I could not. May Mighty Lord accept your good deeds and help you when you need.

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-10-16 02:51:17 -0500 )edit
1

No problem. But I'm curious how you installed the PR2 pkgs in the first place. They should've resulted in the missing pkgs being installed automatically.

And in general: if something complains about plugins not being found, try to find out which pkg they should come with. Then install that.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-16 06:22:40 -0500 )edit

I shall definitely do it and be careful in future. Thank gvdhoorn for your extremely valuable time.

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-10-16 23:10:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-15 00:08:14 -0500

Seen: 389 times

Last updated: Oct 16 '16