Ask Your Question
1

Failed to load motion_planning_rviz_plugin.so

asked 2012-05-12 17:22:29 -0500

tor gravatar image

updated 2012-05-15 00:14:05 -0500

Hi All,

To visualize the path generated by OMPL, I follow this this tutorial.

Unluckly, when adding a Planning Display on rviz, I got:

[ERROR] [1336877297.396395409]: The plugin for class 'motiong_planning_rviz_plugin/Planning' failed to load.  Error: Failed to load library /opt/ros/fuerte/stacks/arm_navigation/motion_planning_rviz_plugin/lib/libmotion_planning_rviz_plugin.so. Make sure that you are calling the PLUGINLIB_REGISTER_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Cannot load library: No manifest in /opt/ros/fuerte/stacks/arm_navigation/motion_planning_rviz_plugin/lib/libmotion_planning_rviz_plugin.so: motiong_planning_rviz_plugin__Planning

How could I solve above errors?

Do you think a typo (extra 'g') on "... 'motiong_planning_rviz_plugin/Planning'..." contributes to the error?

I also wonder why the Planning Display on rviz subcribes motion_planning_msgs::KinematicPath instead of arm_navigation_msgs::DisplayTrajectory. What do you think?

I am using ROS Fuerte, Ubuntu 11.10 64-bit and arm_navigation stack installed with

sudo apt-get install ros-fuerte-arm-navigation

Thank you. \update: A ticket has been filed for this.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-05-13 22:52:19 -0500

The extra 'g' is definitely a problem. I wonder how it ended up in your RViz config. Usually, you should be able to load the plugin by clicking "Plugins" -> "Manage..." and checking both check boxes ("Loaded" and "Auto Load") next to "Motion Planning".

Maybe it helps if you delete your ~/.rviz/ config directory first.

edit flag offensive delete link more

Comments

Hi Martin, that typo is in motion_planning_rviz_plugin/plugin_description.xml; https://kforge.ros.org/armnavigation/armnavigation/file/1e25b730b303/motion_planning_rviz_plugin/plugin_description.xml, I have tried to correct it, but the problem remains, any ideas pls?

tor gravatar imagetor ( 2012-05-14 23:22:34 -0500 )edit

Good catch! You should file a bug here and edit your question to include a link to the bug report.

Martin Günther gravatar imageMartin Günther ( 2012-05-14 23:35:27 -0500 )edit

Martin, btw, I do not see a Plugins button in rviz, where is it? In my case, the motion_planning_rviz_plugin is already in DisplayType windows without any efforts, so I am not sure whether this is correct.

tor gravatar imagetor ( 2012-05-14 23:36:06 -0500 )edit

Yes, that is how it should be. Thanks for submitting the bug report!

Martin Günther gravatar imageMartin Günther ( 2012-05-15 05:14:37 -0500 )edit

Hi Martin, do you have any suggestions as workarounds for that please? Thanks.

tor gravatar imagetor ( 2012-05-25 00:26:45 -0500 )edit

You could copy the package to your home directory, fix it there and put it on your ROS_PACKAGE_PATH.

Martin Günther gravatar imageMartin Günther ( 2012-05-28 22:07:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-12 17:22:29 -0500

Seen: 1,320 times

Last updated: May 15 '12