Ask Your Question
1

[move_base] want to completely follow the global path

asked 2016-08-10 06:14:18 -0500

Jam gravatar image

Dear all,
I am using move_base for my robot navigation,
and following the tuning tutorial to adjust my yaml file which used in base_local_planner.
ex:
pdist_scale:1.0
gdist_scale:0.5
But my local plan path is doesn't not follow the global path completely.
image description
Is there any advice for tunning these parameter?
EX: rotate to direction first. Demo video of completely follow the global path

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-08-10 09:13:37 -0500

David Lu gravatar image

One possible answer: the scales are NOT [0,1]. Try cranking pdist_scale up to 11.

edit flag offensive delete link more

Comments

Thank you, David!
Set pdist_scale up to 11 works!
The robot will rotate first, then almost follow the path!
Thanks for your kindly help again :)

Jam gravatar image Jam  ( 2016-08-10 19:53:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2016-08-10 06:14:18 -0500

Seen: 1,058 times

Last updated: Aug 10 '16