how can I set the library search path for the pluginlib?

asked 2016-08-08 05:05:12 -0600

thunderbug gravatar image

updated 2016-08-08 11:55:16 -0600

gvdhoorn gravatar image

I am trying to create an rqt plugin and I have used the image_viewer as a template where I changed all the names and the code to get an empty plugin. This generally worked and I can find my plugin in the dropdown menue of rqt, but when I want to start it it says that it cannot find the library. I have checked that the library is really generated in ~/catkin_ws/devel/lib and when I manually copy the library to /opt/ros/indigo/lib it suddenly finds the library. Where can I extend the search path for the pluginlib?

( in the plugin.xml the path tag is: <library path="lib/librqt_grip_ui"> which should be correct accordingly to all the tutorials that I could find online. "rqt_grip_ui" is the name )

edit retag flag offensive close merge delete

Comments

Shouldn't the library path include a ${prefix} bit?

gvdhoorn gravatar imagegvdhoorn ( 2016-08-08 11:55:03 -0600 )edit

I found the Problem. You have to source the setup.bash in /op/ros/(your_distro) AND the setup.bash in your ~/catkin_ws/devel

I only had the first one in my .bashrc and so it didn't look for rqt Plugins and rosnodes in my carkin Workspace.

thunderbug gravatar imagethunderbug ( 2016-08-08 12:50:29 -0600 )edit

The second setup file will implicitly source the first one if you have build the workspace with the first one being sourced in the first place.

Dirk Thomas gravatar imageDirk Thomas ( 2016-08-08 13:06:35 -0600 )edit

I am having a similar issue: one of my plugins is dependent on the MPI library. I can use the code anywhere except I cant use it in RViz. The plugin compiles, but when running the code I get an error about Pluginlib not finding the MPI symbol. Is there a way to set the include path manually?

jp gravatar imagejp ( 2018-01-24 09:30:10 -0600 )edit