ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

ros_arduino_bridge configuration error

asked 2016-07-13 10:32:45 -0600

Emilien gravatar image

Hi, i follow read me tutorial of ros_arduino_bridge in this link link text and when i run roslaunch ros_arduino_python arduino.launch, i receive this error:

Connecting to Arduino on port /dev/ttyACM0 ... Traceback (most recent call last): File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/", line 195, in <module> myArduino = ArduinoROS() File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/", line 87, in __init__ self.controller.connect() File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/src/ros_arduino_python/", line 68, in connect test = self.get_baud() File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/src/ros_arduino_python/", line 261, in get_baud return int(self.execute('b')); File "/home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/src/ros_arduino_python/", line 178, in execute return int(value) TypeError: int() argument must be a string or a number, not 'NoneType' [INFO] [WallTime: 1468423834.069478] Stopping the robot... [INFO] [WallTime: 1468423834.070452] Shutting down Arduino Node... [arduino-1] process has died [pid 10979, exit code 1, cmd /home/irisecesi/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/ __name:=arduino __log:=/home/irisecesi/.ros/log/3ed0dd4c-4904-11e6-9d6d-eca86bf97b81/arduino-1.log]. log file: /home/irisecesi/.ros/log/3ed0dd4c-4904-11e6-9d6d-eca86bf97b81/arduino-1*.log all processes on machine have died, roslaunch will exit shutting down processing monitor... ... shutting down processing monitor complete done

What can i do please?

edit retag flag offensive close merge delete


Can you please provide the following additional information: (1) Your version of Ubuntu, (2) Your version of ROS, (3) Which branch of ros_arduino_bridge are you using (e.g. hydro-devel, indigo-devel), (4) which Arduino board are you using (e.g. Uno, Mega, etc.)

Pi Robot gravatar image Pi Robot  ( 2016-07-13 17:45:36 -0600 )edit

I use ubuntu 14.04 , ros indigo, arduino mega and ros_arduino_bridge indigo-devel

Emilien gravatar image Emilien  ( 2016-07-14 07:26:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-07-14 08:30:31 -0600

Pi Robot gravatar image

updated 2016-07-14 08:38:21 -0600

Thanks for the additional info. I have added a try-except around the get_baud() function that should fix this. Please do a "git pull" and see if it works for you. It might also help to increase the timeout parameter in your params file from the default of 0.1 to 0.5. There should be no need to rerun catkin_make.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-07-13 10:32:45 -0600

Seen: 196 times

Last updated: Jul 14 '16