Ask Your Question
0

ros_arduino_bridge fighting me every step of the way, Raspberry Pi, Hydro, Wheezy

asked 2014-12-15 18:44:43 -0500

emccarron72 gravatar image

updated 2014-12-16 01:24:52 -0500

gvdhoorn gravatar image

I've been trying to avoid asking what I'm hoping has an obvious answer, but after 30 hours of struggling with this, it's time to ask the experts.

I've installed ROS (Hydro) on an Raspberry PI. It seems to have gone as well as could be expected. I can start roscore, etc.

I've already modified the arduino firmware to do what I wanted (simple encoder, different h-bridge) and it seems to be working from the serial monitor.

However, when I try to launch ros_arduino_bridge, I get the following:

ERROR:  cannot launch node of type [ros_arduino_python/arduino_node.py]: can't locate node [arduino_node.py] in package [ros_arduino_python]

I'm a total ros and python newb, and linux is not far behind. I know enough to be dangerous.

ROS lives (I think) in the directory ~/ros_catkin_ws.

Google isn't helping. I've been through fuerte from an image for the pi, groovy from an image, indigo from repository, and now hydro from repository.

Help?

Thanks,

Ed

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-16 01:19:01 -0500

gvdhoorn gravatar image

updated 2014-12-16 01:21:50 -0500

ERROR: cannot launch node of type [ros_arduino_python/arduino_node.py]: can't locate node [arduino_node.py] in package [ros_arduino_python]

I'm by no means an RPI wizard, but have you made sure you've got the ros_arduino_python package installed on your RPI? If so, check that it has the arduino_node.py Python script in there somewhere. That is basically what the error is telling you: it cannot find the requested executable (in this case a Python script) in the package specified (in this case ros_arduino_python).

Finally, make sure you've sourced the appropriate setup.bash. If you have the ros_arduino_bridge packages in ~/catkin_ws, then you should, after catkin_make-ing, source ~/catkin_ws/devel/setup.bash. If you fail to do this, ROS won't be able to find the packages in your catkin workspace.

If you installed ros_arduino_bridge using Debians, then sourcing the normal setup.bash in /opt/ros/DISTRO/ should work for you.

edit flag offensive delete link more

Comments

That moved me along a step -- thanks! Up next: Figuring out why this install seems to have skipped so many things...

Off to experiment!

emccarron72 gravatar image emccarron72  ( 2014-12-16 12:04:18 -0500 )edit

Nice. Please use comments next time for these things: answers are really just for answers to the question. I've changed your's into a comment.

gvdhoorn gravatar image gvdhoorn  ( 2014-12-16 12:18:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-15 18:44:43 -0500

Seen: 273 times

Last updated: Dec 16 '14