Ask Your Question
0

ERROR: [GroupBulkRead::RxPacket] ID 8 result : -3002 !!!!!!!!!!

asked 2016-06-20 12:20:57 -0600

RohitM gravatar image

I am extending the code for the Robotis Manipulator from 6 motors to 7 motors. When I roslaunch the manipulator_manager.launch file, the 7 motors are getting detected. But when I try to Set Base Mode in the GUI, it is giving the error message as shown below:

[GroupBulkRead::RxPacket] ID %d result : %d !!!!!!!!!!

Below is the snippet of the code where the error statement is being printed:

int GroupBulkRead::RxPacket()
{
    int _cnt            = id_list_.size();
    int _result         = COMM_RX_FAIL;

    last_result_ = false;

    if(_cnt == 0)
        return COMM_NOT_AVAILABLE;

    for(int _i = 0; _i < _cnt; _i++)
    {
        UINT8_T _id = id_list_[_i];

        _result = ph_->ReadRx(port_, length_list_[_id], data_list_[_id]);
        if(_result != COMM_SUCCESS)
        {
            fprintf(stderr, "[GroupBulkRead::RxPacket] ID %d result : %d !!!!!!!!!!\n", _id, _result);
            return _result;
        }
    }

    if(_result == COMM_SUCCESS)
        last_result_ = true;

    return _result;
}

Does anyone have any suggestions?

edit retag flag offensive close merge delete

Comments

I have same problem too. Are you solve?

Youjun gravatar imageYoujun ( 2016-10-13 15:04:54 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-18 08:23:08 -0600

RohitM gravatar image

By going through the code again I noticed that there is a parameter called LATENCY_TIMER. This needs to be increased when you are increasing the number of motors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-20 12:20:57 -0600

Seen: 94 times

Last updated: Oct 18 '16