Ask Your Question
0

ROS Industrial Moveit is stuck indefinitely

asked 2016-06-01 02:13:43 -0500

karthikj219 gravatar image

updated 2016-06-01 02:44:28 -0500

gvdhoorn gravatar image

I've set up ABB RobotStudio according to the ROS wiki tutorial. I'm currently using ROS Indigo on Ubuntu 14.04.4 with RobotStudio 6.03. The virtual controller log says that the Linux PC is connected. When I run

roslaunch abb_irb2400_moveit_config moveit_planning_execution.launch robot_ip:=10.140.60.190

the program runs, and I'm able to see Rviz. On trying basic motion planning, the planning happens successfully, but on executing, my Linux terminal is stuck on this:

[ INFO] [1464764643.403390805]:Received new trajectory execution service request...

At the same time, the virtual controller log displays:

ROS_MotionServer -> Sending 20 points to MOTION task

The robot in RobotStudio doesn't move at all. The initial positions for Rviz as well as RobotStudio are the same. Any idea what's wrong?

edit retag flag offensive close merge delete

Comments

Things to check: robot is in auto mode?

gvdhoorn gravatar image gvdhoorn  ( 2016-06-01 04:47:10 -0500 )edit

It was in manual, I solved it though. See below.

karthikj219 gravatar image karthikj219  ( 2016-06-01 05:12:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-01 05:12:11 -0500

karthikj219 gravatar image

I solved it on my own. Turns out that making execution_planning_duration=false means you have to remove the allowed_execution_duration_scaling and the allowed_goal_duration_margin. I had to do this because I was initially getting the error

Controller is taking too long to execute trajectory

So, replacing the goal duration and execution duration scaling parameters did the trick.

edit flag offensive delete link more

Comments

You shouldn't have to 'remove' those parameters if you correctly disabled the execution monitoring. Did you follow the procedure documented in How do I disable execution_duration_monitoring ? After disabling, the other parameters should be ignored.

gvdhoorn gravatar image gvdhoorn  ( 2016-06-01 05:35:33 -0500 )edit

I used the link you've mentioned above to disable duration monitoring. It didn't directly work, until I commented out the other 2 parameters. Is this a possible bug?

karthikj219 gravatar image karthikj219  ( 2016-06-01 06:10:46 -0500 )edit

You set the parameter to false in the sub namespace? It's always worked for me that way, so I'd be surprised if this is no longer the case.

gvdhoorn gravatar image gvdhoorn  ( 2016-06-01 06:27:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-06-01 02:13:43 -0500

Seen: 505 times

Last updated: Jun 01 '16