Ask Your Question
0

Problem with Autonomous robot motion: amcl

asked 2016-04-27 11:15:50 -0500

b2meer gravatar image

updated 2016-04-28 10:58:42 -0500

My robot has been set up for autonomous motion using amcl & move_base from ROS navigation stack. The robot performs correctly using teleop; and the motors follow the velocity values published by move_base well enough. The problem is that, after defining the path between the robot and the goal position correctly, my robot fails to follow it (the defined path). I have uploaded a video of what the robot's simulation does in rviz here: https://youtu.be/cRTHVMGiG0I

Also, The robot driver subscribes to the rostopic navigation_velocity_smoother/raw_cmd_vel to run the motors (since values are not being published on cmd_vel topic)

Can anyone shed some light on why this is happening? (please watch the video in the provided url)

Here are my move_base parameters:

shutdown_costmaps: false

controller_frequency: 5.0 controller_patience: 3.0

planner_frequency: 1.0 planner_patience: 5.0

oscillation_timeout: 10.0 oscillation_distance: 0.8

base_local_planner: "dwa_local_planner/DWAPlannerROS"

base_global_planner: "navfn/NavfnROS" #alternatives:global_planner/GlobalPlanner

And these are the dwa_planner params:

max_vel_x: 0.5
min_vel_x: 0.0

max_vel_y: 0.0 min_vel_y: 0.0

max_trans_vel: 0.5 min_trans_vel: 0.1
trans_stopped_vel: 0.1

max_rot_vel: 5.0
min_rot_vel: 0.4
rot_stopped_vel: 0.4

acc_lim_x: 0.5 acc_lim_theta: 2.0 acc_lim_y: 0.0

yaw_goal_tolerance: 0.3
xy_goal_tolerance: 0.15

sim_time: 1.0
vx_samples: 6
vy_samples: 1
vtheta_samples: 20

path_distance_bias: 64.0 goal_distance_bias: 24.0 occdist_scale: 0.5
forward_point_distance: 0.325 stop_time_buffer: 0.2
scaling_speed: 0.25
max_scaling_factor: 0.2

oscillation_reset_dist: 0.05

publish_traj_pc : true publish_cost_grid_pc: true global_frame_id: odom

edit retag flag offensive close merge delete

Comments

I can see multiple possible error sources there. (e.g. is this the map for localization? is the robot turning right when you command left? ...) please provide your configurations, maybe a video of Gazebo next to rviz, a bagfile...

mgruhler gravatar image mgruhler  ( 2016-04-28 01:02:26 -0500 )edit

I have added the configuration parameters for move_base and dwa_local planner in the original question. Please refer to them.

b2meer gravatar image b2meer  ( 2016-04-28 11:00:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-05-08 15:11:49 -0500

b2meer gravatar image

I figured out the problem. The base_frame parameter in move_base node was set to base_link. I changed it to base_footprint. Now the robot follows its path properly and reaches its goal. Thanks everyone for help.

edit flag offensive delete link more
0

answered 2016-04-29 03:14:29 -0500

Waseem Anjum gravatar image

Well it seems like you have problem with odometry as well as your robot is not localized properly. I suggest you to check your local/global costmap parameters and also check that in which direction your robot is moving (x or y).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-27 11:15:50 -0500

Seen: 464 times

Last updated: May 08 '16