Ask Your Question
0

How to install Mavros on Raspbian for RPi? [closed]

asked 2016-04-22 09:06:44 -0500

LogicRos gravatar image

Hi all!

I have a Raspberry Pi and I want to install Mavros. I've been trying to install Mavros on Raspberry Pi fallowing this link:

https://github.com/mavlink/mavros/tree/master/mavros

but when I fallow the instructions in section Installation and I write the first command line sudo apt-get install ros-indigo-mavros ros-indigo-mavros-extras show me the next image.

image description

I'm using Ros indigo on RPi.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by LogicRos
close date 2016-04-26 18:26:30.611471

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-04-25 01:33:52 -0500

Femer gravatar image

updated 2016-04-25 01:38:48 -0500

Edit: I just noticed you asked a similar question here ... did you try out the possible solutions posted there ?

Otherwise I think you could try to follow the instructions here: Mavros source Installation. At the end of that page there's also a skye blue box with additional information about raspberry pi.

Hope that helps :)

edit flag offensive delete link more
0

answered 2016-04-22 18:45:14 -0500

Ag gravatar image

updated 2016-04-22 18:46:40 -0500

Hmm..it would seem that your last error notes that there are broken packages that are conflicting with your installation. Perhaps a way to correct the issue is by relying on aptitude to install the packages. Aptitude seems to work with narrowing down problems revolving around broken packages, so it may be of some help.

To install aptitude, use the following command sudo apt-get install aptitude and then try reinstalling your packages with sudo aptitude install ros-indigo-mavros ros-indigo-mavros-extras.

Additionally, I see that the dependencies libboost-filesystem1.54.0 and libboost-system1.54.0 are not able to be installed, so there may be an issue with those two making it not possible to install mavros and mavros extras because of those dependencies being needed to be used for both packages.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-04-22 09:06:44 -0500

Seen: 3,071 times

Last updated: Apr 25 '16