Unmet dependencies installing ros-jade on ubuntu 14.04

asked 2016-04-21 05:39:24 -0600

Jonas25 gravatar image

I'm trying to install ros-jade, but get this error:

{12:29}~ ➭ sudo apt-get install ros-jade-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-jade-desktop-full : Depends: ros-jade-desktop but it is not going to be installed
                         Depends: ros-jade-perception but it is not going to be installed
                         Depends: ros-jade-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I was following the guide and tried to fix the issue:

{12:33}~ ➭ sudo apt-get install libgl1-mesa-dev-lts-utopic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dev-lts-utopic : Depends: mesa-common-dev-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
                              Depends: libgl1-mesa-glx-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed
 qtbase5-dev : Depends: libgles2-mesa-dev or
                        libgles2-dev but it is not installable
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
{12:34}~ ➭

After some searching I found this thread and tried its solution:

{12:34}~ ➭ sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libgl1-mesa-glx-lts-vivid libglapi-mesa-lts-vivid libgles1-mesa-lts-vivid libegl1-mesa-lts-vivid           xserver-xorg-dev-lts-vivid mesa-common-dev-lts-vivid libxatracker-dev-lts-vivid libgles2-mesa-dev-lts-vivid libgles1-mesa-dev-lts-vivid libgl1-mesa-dev-lts-vivid libgbm-dev-lts-vivid libegl1-mesa-dev-lts-vivid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libegl1-mesa-dev-lts-vivid is already the newest version.
libegl1-mesa-lts-vivid is already the newest version.
libgbm-dev-lts-vivid is already the newest version.
libgl1-mesa-dev-lts-vivid is already the newest version.
libgl1-mesa-glx-lts-vivid is already the newest version.
libglapi-mesa-lts-vivid is already the newest version.
libgles1-mesa-dev-lts-vivid is already the newest version.
libgles1-mesa-lts-vivid is already the newest version.
libgles2-mesa-dev-lts-vivid is already the newest version.
libwayland-egl1-mesa-lts-vivid is already the newest version.
libxatracker-dev-lts-vivid is already the newest version.
linux-generic-lts-vivid is already the newest version.
mesa-common-dev-lts-vivid is already the newest version.
xserver-xorg-core-lts-vivid is already the newest version.
xserver-xorg-dev-lts-vivid is already the newest version.
xserver-xorg-input-all-lts-vivid is already the newest version.
xserver-xorg-lts-vivid is already the newest version.
xserver-xorg-video-all-lts-vivid is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 54 not upgraded.

Now I am running out of ideas, what could I try?

edit retag flag offensive close merge delete