Ask Your Question
0

ROS indigo installation for Ubuntu ARM (Jetson TK1) Ubuntu 14.04

asked 2014-10-29 05:01:15 -0600

Andrew.A gravatar image

updated 2014-10-29 05:03:42 -0600

I'm trying to install ROS indigo on my Jetson TK1, following the steps as stated here. However, I'm facing a problem when running sudo apt-get ros-indigo-ros-base. This is the error I receive:

$ sudo apt-get install ros-indigo-ros-base
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-ros-base : Depends: ros-indigo-actionlib but it is not going to be installed
                       Depends: ros-indigo-bond-core but it is not going to be installed
                       Depends: ros-indigo-class-loader but it is not going to be installed
                       Depends: ros-indigo-common-tutorials but it is not going to be installed
                       Depends: ros-indigo-dynamic-reconfigure but it is not going to be installed
                       Depends: ros-indigo-nodelet-core but it is not going to be installed
                       Depends: ros-indigo-pluginlib but it is not going to be installed
                       Depends: ros-indigo-ros-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Can anyone help me out please?

edit retag flag offensive close merge delete

Comments

No I didn't! Just enabled them and it's running great now. Thanks!

Andrew.A gravatar imageAndrew.A ( 2014-10-29 05:23:13 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-10-29 05:13:24 -0600

ahendrix gravatar image

updated 2016-01-31 12:13:03 -0600

Do you have the ubuntu universe and multiverse repositories enabled?

UPDATE

According to https://github.com/ros-perception/ima... ; Nvidia is now packaging a newer version of OpenCV in opencv4tegra, and it's no longer version- or ABI-compatible with the default Ubuntu libraries.

edit flag offensive delete link more

Comments

As noted in http://answers.ros.org/question/22956... , you also need to enable the Ubuntu main repository if it is not enabled.

ahendrix gravatar imageahendrix ( 2016-03-22 00:42:12 -0600 )edit
1

answered 2014-10-29 06:08:44 -0600

StefanG gravatar image

Glad that the orignal problem was solved! Maybe I am ahead of you and you might solve this another way...but I ran into trouble when trying to use ros & opencv (the Tegra version). I sorted it (rather hackish way) and I thought I should post it here for reference at least.

If someone(admin?) feel that this is not the correct place...feel free to remove/correct this.

I ended up creating a "fake" package (using equivs) that tells apt that libopencv + libopencv-dev is already installed. This worked nicely for me and now I am running the tegra-version of opencv under ROS. Very nice...but a little hackish solution to the problem!

Anyhow, this was the contents of the input file for "equivs-build":

Section: misc
Priority: optional
Standards-Version: 3.9.2

Package: libopencv-dev-dummy
Version: 2.4.8
Maintainer: yourname <<a href="mailto:yourname@somemail">yourname@somemail</a>>
Provides: libopencv-calib3d-dev, libopencv-calib3d2.4, 
    libopencv-contrib-dev, libopencv-contrib2.4, 
    libopencv-core-dev, libopencv-core2.4,
    libopencv-dev,
    libopencv-facedetect-dev, libopencv-facedetect2.4, 
    libopencv-features2d-dev, libopencv-features2d2.4, 
    libopencv-flann-dev, libopencv-flann2.4, 
    libopencv-gpu-dev, libopencv-gpu2.4, 
    libopencv-highgui-dev, libopencv-highgui2.4, 
    libopencv-imgproc-dev, libopencv-imgproc2.4,
    libopencv-imuvstab-dev, libopencv-imuvstab2.4,
    libopencv-legacy-dev, libopencv-legacy2.4, 
    libopencv-ml-dev, libopencv-ml2.4,
    libopencv-objdetect-dev, libopencv-objdetect2.4, 
    libopencv-ocl-dev, libopencv-ocl2.4, 
    libopencv-photo-dev, libopencv-photo2.4,
    libopencv-softcascade-dev, libopencv-softcascade2.4,
    libopencv-stitching-dev, libopencv-stitching2.4, 
    libopencv-superres-dev, libopencv-superres2.4, 
    libopencv-video-dev, libopencv-video2.4, 
    libopencv-videostab-dev, libopencv-videostab2.4,
    libopencv-vstab, libopencv-vstab2.4

Description: empty dummy package
   no description

This will get you a "dummy-package" that you simply install using "sudo dpkg -i libopencv-dev-dummy_2.4.8_all.deb". After this, all other packages that depend on opencv will install without trying to install the SW-version of opencv. Make sure you have installed the CUDA-version of OpenCV before running this... Also note that the CUDA-version of OpenCV does not contain the nonfree package, i.e. SURF etc. Have not tried to solve that yet...

edit flag offensive delete link more

Comments

Please ask this as a new question.

ahendrix gravatar imageahendrix ( 2014-10-29 12:14:38 -0600 )edit

It was not a question...just tried to give more hints/solutions in getting OpenCV to work with ROS under Jetson. I looked for this quite a lot, but did not find any solution here. Hence I posted the solution. Maybe it should have been a wiki thing instead? Asked mods in the post to remove if not ok.

StefanG gravatar imageStefanG ( 2014-10-29 12:25:47 -0600 )edit

This is probably better as a wiki page. I'm also not sure that it's correct, because I'm not sure if NVIDIA's OpenCV library is ABI-compatible with the stock OpenCV library or not. You may very well have dynamic linker errors the first time you try to run anything that uses OpenCV.

ahendrix gravatar imageahendrix ( 2014-10-29 12:49:44 -0600 )edit

It actually works very nice. I ran "ar_track_alvar" on it, in combo with usb_cam and that worked very nice.

StefanG gravatar imageStefanG ( 2014-10-29 13:00:41 -0600 )edit

I was following a tutorial here, and I think he did the same thing and created a dummy package!

Andrew.A gravatar imageAndrew.A ( 2014-10-29 21:58:30 -0600 )edit

@StefanG If you wouldnt mind starting a wiki page about this that would be awesome.. Im getting the TK1 soon and am looking for the easiest way to make this work. I will definetely post the steps i took once i get it!

l0g1x gravatar imagel0g1x ( 2014-11-06 16:41:49 -0600 )edit
1

There is a Jetson TK1 page here: http://wiki.ros.org/NvidiaJetsonTK1

ahendrix gravatar imageahendrix ( 2014-12-31 03:15:12 -0600 )edit

like the page, look forward to better instructions!

ZiyangLI gravatar imageZiyangLI ( 2015-01-05 21:16:04 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-29 05:01:15 -0600

Seen: 6,541 times

Last updated: Jan 31 '16