Ask Your Question
0

Applying generated velodyne calibration file(yaml) on Ubuntu 14.04 with ROS-INDIGO

asked 2014-09-16 03:05:43 -0600

teawonHan gravatar image

updated 2016-07-05 04:53:17 -0600

gvdhoorn gravatar image

Hello, I am using 64E_S2 for a year. I used two commands to get 3d point-clouds from the Lidar throughout ROS.

The two commands are (1) rosrun velodyne_driver velodyne_node _model:=64E_S2 _rpm:=0600 and (2) rosrun nodelet nodelet standalone velodyne_pointcloud/CloudNodelet transform_node _calibration:=db.yaml.

The file, db.yaml, is generated by using "rosrun velodyne_pointcloud gen_calibration.py db.xml" where db.xml file is provided with the Lidar. Actually, it worked well under ubuntu 12.04 with ROS-hydro.

The problem is here. I upgrade Ubuntu-version to 14.04 and ROS-indigo, and installed ros-indigo-velodyne. However, when I tried to same commands with same 'db.yaml' file, I got error messages like below.

YAML Exception: yaml-cpp: error at line 0, column 0: bad conversion

and

[ERROR] [1410851740.164624564]: Unable to open calibration file: db.yaml

I thought that I have to generate db.yaml again, but it still not work. In addition, I would like to check what the problem is among the generated file 'db.yaml' and installed velodyne driver. So, I tried roslaunch velodyne_pointcloud 32e_points.launch because it used the yaml file which is provided from ROS. Interestingly, it is working well loading the calibration file without error.

Therefore, I just guess that I should have to generate yaml file differently not following general way. However, one strange thing is that generated file and provided file are following same format. I think that it is better to ask here about this problem.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-12-29 13:57:53 -0600

tfoote gravatar image

The error is that it cannot open the file. This will be caused by two common errors. It may have the wrong permissions or it may be looking in the wrong place for the file.

edit flag offensive delete link more
0

answered 2016-07-05 04:35:06 -0600

jiashiwei gravatar image

you can use 32db.xml instead of db.xml, because there is no db.xml in indigo

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-09-16 03:05:43 -0600

Seen: 872 times

Last updated: Jul 05 '16