Ask Your Question
0

Unmet dependencies while installing ROS Jade on Ubuntu 14.04.2

asked 2016-03-15 03:45:55 -0500

Specas gravatar image

Hi,

I have followed the installation procedure on the website. When I execute

sudo apt-get install ros-jade-desktop-full

I get the following error message

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-jade-desktop-full : Depends: ros-jade-perception but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried installing the system dependencies as stated in the installation guide :

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic



sudo apt-get install libgl1-mesa-dev-lts-utopic

It still gives me the same error.

I have also tried to install the package separately

sudo apt-get install ros-jade-perception

Even this doesn't seem to work.

Any help is appreciated.

Thank you

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2016-03-20 08:21:22 -0500

alphavanderson gravatar image

try this : sudo apt-get install tcl-vtk , then sudo apt-get install python-vtk and then sudo apt-get install ros-jade-desktop-full . It works for me.

edit flag offensive delete link more

Comments

This works!! Thanks a lot.

Specas gravatar image Specas  ( 2016-04-01 12:27:20 -0500 )edit

Thanks! This worked for me.

Klas gravatar image Klas  ( 2016-04-23 07:18:13 -0500 )edit

Worked for me as well.

chambana gravatar image chambana  ( 2016-12-18 15:04:53 -0500 )edit
0

answered 2016-03-15 04:35:01 -0500

Reza1984 gravatar image

Apparently, ROS Jade has some issues with Ubuntu 14.04 as I faced too.
In the installation tutorial (section 1.4 in the box) there is a solution for it. However, it didn't work for me! and I couldn't find any solution for that dependency issue. I ended up using indigo and it works like charm!

edit flag offensive delete link more

Comments

Thanks!

Are there any major differences between jade and indigo?

Specas gravatar image Specas  ( 2016-03-15 10:59:34 -0500 )edit

Check the following link:

http://wiki.ros.org/jade/Migration

Reza1984 gravatar image Reza1984  ( 2016-03-15 21:29:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-15 03:45:55 -0500

Seen: 552 times

Last updated: Mar 20 '16