rviz segmentation fault on startup

asked 2016-03-30 10:28:31 -0600

nickkazepis gravatar image

I tried http://wiki.ros.org/action/fullsearch... with no luck

user@RAMCIPVM:~$ gdb rviz
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from rviz...(no debugging symbols found)...done.
(gdb) run
Starting program: /opt/ros/indigo/bin/rviz 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffdd22a700 (LWP 7895)]
[New Thread 0x7fffdca29700 (LWP 7896)]
[New Thread 0x7fffd70e1700 (LWP 7897)]
[New Thread 0x7fffd68e0700 (LWP 7898)]
[New Thread 0x7fffd60df700 (LWP 7899)]
[ INFO] [1459351486.321949168]: rviz version 1.11.10
[ INFO] [1459351486.322065318]: compiled against OGRE version 1.8.1 (Byatis)
[New Thread 0x7fffd56d2700 (LWP 7903)]
[New Thread 0x7fffd4ed1700 (LWP 7904)]
[New Thread 0x7fffc3fff700 (LWP 7905)]
[New Thread 0x7fffc37fe700 (LWP 7910)]
[New Thread 0x7fffc0c7d700 (LWP 7911)]
[Thread 0x7fffc0c7d700 (LWP 7911) exited]
[New Thread 0x7fffc047c700 (LWP 7912)]
[Thread 0x7fffd68e0700 (LWP 7898) exited]
[New Thread 0x7fffd68e0700 (LWP 7913)]
[New Thread 0x7fffc0c7d700 (LWP 7914)]
[New Thread 0x7fffae6a0700 (LWP 7915)]
[New Thread 0x7fffade9f700 (LWP 7916)]
[ INFO] [1459351487.198225919]: Stereo is NOT SUPPORTED
[ INFO] [1459351487.199172862]: OpenGl version: 2.1 (GLSL 1.2).
[New Thread 0x7fffacc3d700 (LWP 7930)]
[New Thread 0x7fff97fff700 (LWP 7931)]
OpenGL Warning: vboxCall failed with VBox status code -39

OpenGL Warning: vboxCall retry(1) succeeded

Program received signal SIGSEGV, Segmentation fault.
0x00007fffc182365d in ?? () from /usr/lib/x86_64-linux-gnu/VBoxOGLpackspu.so
(gdb) bt
#0  0x00007fffc182365d in ?? () from /usr/lib/x86_64-linux-gnu/VBoxOGLpackspu.so
#1  0x00007fffc1867976 in crPackExpandArrayElement () from /usr/lib/x86_64-linux-gnu/VBoxOGLpackspu.so
#2  0x00007fffc1867f52 in crPackExpandDrawArrays () from /usr/lib/x86_64-linux-gnu/VBoxOGLpackspu.so
#3  0x00007fffc16ebe9a in ?? () from /usr/lib/x86_64-linux-gnu/VBoxOGLpackspu.so
#4  0x00007fffaf15a5b2 in Ogre::GLRenderSystem::_render(Ogre::RenderOperation const&) () from /usr/lib/x86_64-linux-gnu/OGRE-1.8.0/RenderSystem_GL.so
#5  0x00007ffff3adbb50 in Ogre::SceneManager::renderSingleObject(Ogre::Renderable*, Ogre::Pass const*, bool, bool, Ogre::HashedVector<Ogre::Light*> const*) ()
   from /usr/lib/x86_64-linux-gnu/libOgreMain.so.1.8.1
#6  0x00007ffff3a88459 in Ogre::QueuedRenderableCollection::acceptVisitorDescending(Ogre::QueuedRenderableVisitor*) const () from /usr/lib/x86_64-linux-gnu/libOgreMain.so.1.8.1
#7  0x00007ffff3a88519 in Ogre::QueuedRenderableCollection::acceptVisitor(Ogre::QueuedRenderableVisitor*, Ogre::QueuedRenderableCollection::OrganisationMode) const ()
   from /usr/lib/x86_64-linux-gnu/libOgreMain.so.1.8.1
#8  0x00007ffff3ac8cbc in Ogre::SceneManager::renderBasicQueueGroupObjects(Ogre::RenderQueueGroup*, Ogre::QueuedRenderableCollection::OrganisationMode) ()
   from /usr/lib/x86_64-linux-gnu/libOgreMain.so.1.8.1
#9  0x00007ffff3aca45b in Ogre::SceneManager::renderVisibleObjectsDefaultSequence() () from /usr/lib/x86_64-linux-gnu/libOgreMain.so.1.8.1
#10 0x00007ffff3adac84 in Ogre::SceneManager::_renderScene(Ogre::Camera*, Ogre::Viewport*, bool) () from /usr/lib/x86_64-linux-gnu ...
(more)
edit retag flag offensive close merge delete

Comments

From the backtrace it looks like VirtualBox's graphic driver is falling over. rviz may not work with your current VM setup, either due to your VirtualBox version or due to your Host machine's video card/driver.

William gravatar image William  ( 2016-03-30 17:17:29 -0600 )edit