Ask Your Question
0

Raspberry pi 2B+ ros indigo

asked 2016-03-29 17:25:36 -0500

Chickenman gravatar image

updated 2016-03-29 17:38:35 -0500

Hi guys I am running ros indigo on my raspberry pi 2b+. I created robot driver for my arm manipulator which is implementation of 3 processes. Main process is service and communicates via usb-serial interface/rs232. 2nd proces is servis which generate messages for main procesess and controlling them and do some basic commutations and the last one is joint_states topic which is communicating with main proces via servis and publishing joint_states. Firstly i had this program on my computer and it could easily publish joint states every 80 ms. But after compilation on raspberry pi . I takes 400 ms to publish joint states of my 6 -dof manipulator and I am not talking about any other control. Is it normally so slow or am I doing something wrong. Can you give me some hints ? Thank you for any advice. Is any there problem with socket communication and publishing topics on raspberry? because it is really so slow

Thanky you for your answers

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-30 15:27:28 -0500

Chickenman gravatar image

Ok so I found solution for my problem. Services were not able to communicate faster than 20 Hz on raspberry. I also tried this solution http://answers.ros.org/question/99746... but it did not help me at all. So I changed the architecture of my program replaced services with topics add one more thread and now it is working without any problems.

edit flag offensive delete link more
0

answered 2016-03-29 17:33:21 -0500

duck-development gravatar image

If you use the building rs233 you may try an USB converter. Have you blocking read ? What is your CPU load? On the pi and you PC?

Do you have graphics output on the pi RViz?

edit flag offensive delete link more

Comments

I also tried directly usb serial interface and it is still the same my cpu load is 52 % and I am using just console interface not graphical. Raspberry should be used just as a driver controller and I am planning to publish joint_states to my computer. using wifi and connecting ros cores

Chickenman gravatar image Chickenman  ( 2016-03-29 17:41:21 -0500 )edit

python process is eating half of my cpu usage 53 % and it could be the problem in my opinion

Chickenman gravatar image Chickenman  ( 2016-03-30 06:35:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-29 17:25:36 -0500

Seen: 105 times

Last updated: Mar 30 '16