Ask Your Question
0

Problem using the provided groovy RPi Image

asked 2013-05-28 03:16:10 -0500

jmueller gravatar image

updated 2014-01-28 17:16:40 -0500

ngrennan gravatar image

Hi Everyone!

So I was going for a quick test using the image provided here: ros.org/wiki/groovy/Installation/Raspbian/Source (sorry, I'm new here and not allowed to post Hyperlinks). After I flashed it to an SDcard and booted I found that ROS does not seem to be present at all (echo $ROS_DISTRO returns nothing, the different ROS_ variables are not present). I also tried setting up my WiFi, with no success (Dongle visible in lsusb, but not in lsmod, nor in ifconfig). When I tried to use the wpa_gui from the X environment, the Pi did not respond to keyboard or mouse input anymore. All the devices mentioned before are connected using a powered USB-hub. As a matter of fact, the Pi itself is powered from that hub.

So now I am wondering: either I am doing strange mistakes at many places or the image provided does not work (the way I think it should - Maybe I misunderstood the introductory text and only the source should be present. But what sense would be in that?). Has anyone tested the functionality of the mentioned image and could give me a hint as to what it is?

Cheers

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-05-28 06:08:46 -0500

The Raspi will not work will all WiFi dongles, check here for which have been tested. You may of blown the polyfuse if you drew too much current over 150 mA without external power. Does it work without the WiFi? I use that image that kalectro kindly provided and have no problems with WiFi or ROS. Source the catkin folders also since I believe most the packages are compiled from source.

edit flag offensive delete link more

Comments

The WiFi Dongle works with the Pi, I used it with the other image I mentioned above (that one did not have tf, among others, which I need to use). But I will have a look at the kalectro image, thanks for the hint!

jmueller gravatar image jmueller  ( 2013-05-28 06:44:57 -0500 )edit

Here is the link to his original post on the Raspi forums http://www.raspberrypi.org/phpBB3/viewtopic.php?f=37&t=6552&p=354127

tonybaltovski gravatar image tonybaltovski  ( 2013-05-28 06:56:29 -0500 )edit
1

answered 2013-05-30 21:23:56 -0500

jmueller gravatar image

updated 2013-06-05 01:10:56 -0500

Thanks so much to balto and davinci!

The download balto indicated (http://www.raspberrypi.org/phpBB3/viewtopic.php?f=37&t=6552&p=354127) is a little cumbersome (the fourth attempt did finally work w/o a CRC error), but the image itself works like a charm. Of course, the setup.bash needs to be sourced to use groovy (I used source /opt/ros/groovy/ros_catkin_ws/install_isolated/setup.bash and echo "source ~/catkin_ws/devel/setup.bash >> ~/.bashrc, the latter may be sufficient, followed by the usual source ~/.bashrc), but WiFi works instantly (with a Realtek-Chipset on the WiFi dongle). It does, however, barely fit on a 16GB SD card. As stated on the RPi forum, one might want to remove the two swapfiles used during compilation from "/" (sudo rm /swapfile*) to gain around 4GB of space.

EDIT: After some hazzle with the Image I swapped over to a stock image and installed ROS using a repository. The steps taken are described in a tutorial: http://www.ros.org/wiki/asctec_mav_framework/Tutorials/Raspberry%20Pi%20Setup (humm... in the preview the link worked, but for the final version, it is parsed completely different. Funny!) - it does not lead to a full ROS install, but should work for most basic stuff. You will most likely only want the first steps.

edit flag offensive delete link more

Comments

Your method is better, I just did a fresh install. Thank you!

tonybaltovski gravatar image tonybaltovski  ( 2013-06-05 08:13:57 -0500 )edit
1

answered 2013-05-28 03:52:14 -0500

davinci gravatar image

Did you do:

echo "source /opt/ros/groovy/setup.bash" >> ~/.bashrc
source ~/.bashrc

The other problem, the RPi has stability issues with power supplies as you probably know. Perhaps try to power the RPi from a seperate power supply. Did the wifi work on other distributions?

edit flag offensive delete link more

Comments

OK, so this did not work the way I expected it to. sourcing does actually help, thanks for that. But for the other Point: the exact same setup worked with another image, yes. However, I will try a different power supply.

jmueller gravatar image jmueller  ( 2013-05-28 04:30:41 -0500 )edit

So, I tried some different methods to supply power (Mobile Phone Charger, USB 3.0 Port) and ended up with the same result - WiFi dongle is not usable (the driver is installed), startx starts x, but my input devices won't work.

I also got a new error message popping up when starting the GUI, some Openbox Syntax Error in an XML file. I guess, this is uncorrelated to the other problem.

jmueller gravatar image jmueller  ( 2013-05-28 04:46:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-28 03:16:10 -0500

Seen: 374 times

Last updated: Jun 05 '13