Ask Your Question
1

Raspberry Pi Desktop Build Error QT

asked 2013-06-15 14:04:47 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I'm building the full desktop version of ROS on a raspberry pi following these instructions: http://www.ros.org/wiki/groovy/Installation/Raspbian/Source

Currently I am at step 6

I'm not sure what is causing the error, here is the build log:

[ 84%] Running SIP generator for qt_gui_cpp_sip Python bindings...
roovy/share/python_qt_binding/cmake/shiboken_helper.cmake:11 (find_package):
  By not providing "FindGeneratorRunner.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "GeneratorRunner", but CMake did not find one.

  Could not find a package configuration file provided by "GeneratorRunner"
  with any of the following names:

    GeneratorRunnerConfig.cmake
    generatorrunner-config.cmake

  Add the installation prefix of "GeneratorRunner" to CMAKE_PREFIX_PATH or
  set "GeneratorRunner_DIR" to a directory containing one of the above files.
  If "GeneratorRunner" provides a separate development package or SDK, be
  sure it has been installed.
Call Stack (most recent call first):
  src/qt_gui_cpp_shiboken/CMakeLists.txt:41 (include)


CMake Warning at /opt/ros/groovy/share/python_qt_binding/cmake/shiboken_helper.cmake:18 (message):
  Shiboken binding generator NOT available.
Call Stack (most recent call first):
  src/qt_gui_cpp_shiboken/CMakeLists.txt:41 (include)


-- SIP binding generator available.
-- Python binding generators: sip
-- Configuring done
-- Generating done
-- Build files have been written to: /opt/ros/groovy/ros_catkin_ws/build_isolated/qt_gui_cpp
==> make -j1 -l1 in '/opt/ros/groovy/ros_catkin_ws/build_isolated/qt_gui_cpp'
<== Failed to process package 'qt_gui_cpp': 
  Command '/opt/ros/groovy/env.sh make -j1 -l1' returned non-zero exit status 2

Reproduce this error by running:
==> /opt/ros/groovy/env.sh make -j1 -l1

I did manage to find one thread on this, but it was left unanswered. Does anyone recognize the error, and know how to fix it? Thanks!

UPDATE:

I managed to get a slightly different error after I ran

sudo apt-get install qt-sdk

This is what I got:

[ 84%] Running SIP generator for qt_gui_cpp_sip Python bindings...
sh: 1: /usr/bin/sip: not found
Error: Unable to open
"/opt/ros/groovy/ros_catkin_ws/build_isolated/qt_gui_cpp/sip/qt_gui_cpp_sip/pyqtscripting.sbf"
make[2]: *** [sip/qt_gui_cpp_sip/Makefile] Error 1
make[1]: *** [src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2
make: *** [all] Error 2
Traceback (most recent call last):
  File "./src/catkin/bin/../python/catkin/builder.py", line 717, in build_workspace_isolated
    number=index + 1, of=len(ordered_packages)
  File "./src/catkin/bin/../python/catkin/builder.py", line 497, in build_package
    install, force_cmake, quiet, last_env, cmake_args, make_args + catkin_make_args
  File "./src/catkin/bin/../python/catkin/builder.py", line 353, in build_catkin_package
    run_command(make_cmd, build_dir, quiet)
  File "./src/catkin/bin/../python/catkin/builder.py", line 198, in run_command
    raise subprocess.CalledProcessError(proc.returncode, ' '.join(cmd))
CalledProcessError: Command '/opt/ros/groovy/env.sh make -j1 -l1' returned non-zero exit status 2
<== Failed to process package 'qt_gui_cpp':
  Command '/opt/ros/groovy/env.sh make -j1 -l1' returned non-zero exit status 2

Reproduce this error by running:
==> /opt/ros/groovy/env.sh make -j1 -l1

Command failed, exiting.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-07-03 22:50:50 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This might not be exactly what you are looking for, but qt_gui_cpp has been built for RPi on ROS Groovy, it is available in a repository, you will find details about it on the following page: http://www.ros.org/wiki/groovy/Installation/Raspbian

I would only advise you to build from source what you can not find in this binary repository, e.g. dry packages, especially since it takes a lot of time and is more error-prone.

edit flag offensive delete link more

Comments

Sounds like a better idea. For the time being I've moved over to an ubuntu VM so I can learn how to use ROS. Once I go to deploy it I'll take this approach to getting it running on the RPi. Thanks!

AlphaSierra gravatar imageAlphaSierra ( 2013-07-04 09:01:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-15 14:04:47 -0600

Seen: 850 times

Last updated: Jul 03 '13