Ask Your Question
1

Getting "Aria.h: file not found" when installing rosaria

asked 2013-10-17 07:30:48 -0600

sucaro gravatar image

updated 2014-01-28 17:18:16 -0600

ngrennan gravatar image

Ubuntu 12.04.3, ros groovy.

I am following a ROSARIA tutorial (can't post links)
I know that it is an hydro tutorial, but I have the same issue with groovy version. Everything works well until catkin_make command at point 1.4.

I allways get this:

RosAria.cpp:3:18: error fatal: Aria.h: No such file or directory.
Compilation finished.
make[2]: [rosaria/CMakeFiles/RosAria.dir/RosAria.cpp.o] Error 1
make[1]: [rosaria/CMakeFiles/RosAria.dir/all] Error 2
make:[all] Error 2
Invoking "make" failed

Where should be placed that header file? Where can I find it?

Thanx for your time! :)

edit retag flag offensive close merge delete

Comments

Aria.h should be in /usr/local/Aria/include. You must either use `rosdep update; rosdep install rosaria`, or install ARIA seperately. Are you using this: http://wiki.ros.org/ROSARIA/Tutorials/How%20to%20use%20ROSARIA ? Note that the instructions for groovy and hydro are different there.

ReedHedges gravatar imageReedHedges ( 2013-10-17 08:05:28 -0600 )edit

Hi! thanks for your help. Yes, I am using that tutorial. "rosdep update" and "rosdep install rosaria" commands end with no errors. The problem comes with "catkin_make". I tried both groovy and hydro versions because hydro one worked fine for a co-worker. But both versions die at catkin_make step.

sucaro gravatar imagesucaro ( 2013-10-17 08:18:24 -0600 )edit

Does /usr/local/Aria/include/Aria.h exist? If so, what is printed out by catkin_make before that error?

ReedHedges gravatar imageReedHedges ( 2013-10-17 09:43:36 -0600 )edit

Base path: /home/marcos/catkin_ws Source space: /home/marcos/catkin_ws/src Build space: /home/marcos/catkin_ws/build Devel space: /home/marcos/catkin_ws/devel Install space: /home/marcos/catkin_ws/install #### #### Running command: "make cmake_check_build_system" in "/home/marcos/catkin_ws/build"

sucaro gravatar imagesucaro ( 2013-10-17 22:23:51 -0600 )edit

#### #### #### Running command: "make -j1 -l1" in "/home/marcos/catkin_ws/build" #### [ 16%] Built target rosaria_gencfg [ 33%] Building CXX object rosaria/CMakeFiles/RosAria.dir/RosAria.cpp.o /home/marcos/catkin_ws/src/rosaria/RosAria.cpp:3:18: error fatal: Aria.h: No such file or directory

sucaro gravatar imagesucaro ( 2013-10-17 22:24:12 -0600 )edit

MAN!! /usr/local/Aria/include dir is completely empty :S, but I got no errors previous steps

sucaro gravatar imagesucaro ( 2013-10-17 22:34:52 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-21 05:50:20 -0600

ReedHedges gravatar image

updated 2013-10-21 05:51:01 -0600

It looks like rosdep install rosaria is not correctly installing the ARIA header files. You can instead install one of these packages (use dpkg -i ...):

For 32-bit http://robots.mobilerobots.com/ARIA/download/current/libaria_2.8.0+ubuntu12+gcc4.6_i386.deb

For 64-bit http://robots.mobilerobots.com/ARIA/download/current/libaria_2.8.0+ubuntu12+gcc4.6_amd64.deb

And then try catkin_make (without running rosdep).

...

If you want to help troubleshoot the underlying problem you can do this:

sudo apt-get remove libaria-sourcedep

rosdep install rosaria >log 2>&1

Then attach the log file here or put it on pastebin.com or send it to me reed.hedges@adept.com

edit flag offensive delete link more

Comments

You can find the current downloads on the ARIA wiki page here: http://robots.mobilerobots.com/wiki/A...

ruffsl gravatar imageruffsl ( 2016-02-20 01:22:00 -0600 )edit
1

answered 2015-09-08 08:45:16 -0600

End-Effector gravatar image

updated 2015-09-08 08:46:12 -0600

THIS IS THE EXACT SOLUTION FOR THIS QUESTION!

Once you have downloaded the Rosaria package do not run catkin_make. First you have to install Aria. That is why you are getting the error "error fatal: Aria.h: No such file or directory."

So what you have to do is:

Open Ubuntu Software Center and install the following: Shearch for Aria and click on "Show 14 technical items". Pick libraria2, libaria-dev and libraria-dev-doc.

Then do catkin_make and it will build the RosAria Package.

edit flag offensive delete link more

Comments

This was my problem; I tried installing rosaria and tried compiling, then installed Aria afterwards and tried compiling rosaria again. It still wasn't finding <aria aria.h="">, but when I removed rosaria en reinstalled it to compile, it worked. Order matters: first Aria, then rosaria.

owengall gravatar imageowengall ( 2018-11-13 12:59:15 -0600 )edit
1

answered 2014-06-05 10:45:00 -0600

RodriguesGabriel gravatar image

I was able to solve this by using rosdep install rosaria then going into rosaria/RosAria.cpp and editing the include line that says #include <Aria.h> to #include </usr/local/Aria/include/Aria.h>. And also, as I had previously used catkin_make, I had to remove the devel and build folders from my workspace root before using it again. It worked like a charm.

edit flag offensive delete link more

Comments

If you run `catkin_make VERBOSE=1` then it will echo the compilation commands it's actually running. Look after `Building CXX object rosaria/CMakeFiles/RosAria.dir/RosAria.cpp.o` or similar to see what `-I` flags its adding to the `c++` command, you should see `-I/usr/local/Aria/include`

ReedHedges gravatar imageReedHedges ( 2014-06-09 14:46:49 -0600 )edit

This solved my problem! Thank you :)

marcobecerrap gravatar imagemarcobecerrap ( 2014-11-24 07:17:26 -0600 )edit

I did not find the .h file in /user/local/Aria. Instead, I find the .h files in /usr/include/Aria/ . And solved my problem.

Gloria@HK gravatar imageGloria@HK ( 2015-09-21 03:11:28 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-17 07:30:48 -0600

Seen: 3,066 times

Last updated: Sep 08 '15