Ask Your Question
2

RosTutorials won't build on Raspberry Pi running Hydro

asked 2014-05-08 05:24:23 -0600

Blueboater gravatar image

I've installed hydro onto a raspberry pi having built the package following the instructions on the website. I've fetched the tutorials from github so I can run the turtlesim. The build keeps failing with the following error. It's probably something fairly obvious...

<== Finished processing package [56 of 63]: 'rosnode'

==> Processing catkin package: 'rospy_tutorials' ==> Building with env: '/home/pi/ros_catkin_ws/install_isolated/env.sh' ==> cmake /home/pi/ros_catkin_ws/src/ros_tutorials/rospy_tutorials -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/rospy_tutorials -DCMAKE_INSTALL_PREFIX=/home/pi/ros_catkin_ws/install_isolated in '/home/pi/ros_catkin_ws/build_isolated/rospy_tutorials' -- Using CATKIN_DEVEL_PREFIX: /home/pi/ros_catkin_ws/devel_isolated/rospy_tutorials -- Using CMAKE_PREFIX_PATH: /home/pi/ros_catkin_ws/install_isolated -- This workspace overlays: /home/pi/ros_catkin_ws/install_isolated -- Using PYTHON_EXECUTABLE: /usr/bin/python -- Python version: 2.7 -- Using Debian Python package layout -- Using CATKIN_ENABLE_TESTING: ON -- Call enable_testing() -- Using CATKIN_TEST_RESULTS_DIR: /home/pi/ros_catkin_ws/build_isolated/rospy_tutorials/test_results -- Found gtest sources under '/usr/src/gtest': gtests will be built -- catkin 0.5.86 -- Using these message generators: gencpp;genlisp;genpy CMake Error at /home/pi/ros_catkin_ws/build_isolated/rospy_tutorials/cmake/rospy_tutorials-genmsg.cmake:3 (message): Could not find messages which '/home/pi/ros_catkin_ws/src/ros_tutorials/rospy_tutorials/msg/HeaderString.msg' depends on. Did you forget to specify generate_messages(DEPENDENCIES ...)?

Cannot locate message [Header] in package [std_msgs] with paths [['/home/pi/ros_catkin_ws/devel_isolated/std_msgs/share/std_msgs/cmake/../msg']] Call Stack (most recent call first): /home/pi/ros_catkin_ws/devel_isolated/genmsg/share/genmsg/cmake/genmsg-extras.cmake:298 (include) CMakeLists.txt:9 (generate_messages)

-- Configuring incomplete, errors occurred! <== Failed to process package 'rospy_tutorials': Command '/home/pi/ros_catkin_ws/install_isolated/env.sh cmake /home/pi/ros_catkin_ws/src/ros_tutorials/rospy_tutorials -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/rospy_tutorials -DCMAKE_INSTALL_PREFIX=/home/pi/ros_catkin_ws/install_isolated' returned non-zero exit status 1

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-17 23:38:36 -0600

covertbagel gravatar image

So I ran into essentially this same issue while compiling ROS Indigo on Raspberry Pi as per [1]. In my case /home/pi/ros_catkin_ws/devel_isolated/std_msgs/share/std_msgs had no msg directory. I worked around it by:

cd /home/pi/ros_catkin_ws/devel_isolated/std_msgs/share/std_msgs
ln -s /home/pi/ros_catkin_ws/src/std_msgs/msg

Not sure why the msg directory didn't get setup in the first place... or why the message search path doesn't just point to src/std_msgs/msg... or how to even configure the search path... but at least the error message was informative enough to get me going again without a lot of frustration.

[1] http://wiki.ros.org/ROSberryPi/Instal...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-08 05:24:23 -0600

Seen: 476 times

Last updated: Jan 17 '15