Ask Your Question
0

Ros concert halts on adding remote machine

asked 2016-03-09 07:39:09 -0600

gavran gravatar image

updated 2016-03-14 12:14:57 -0600

I am going through basic tutorial for setting up distributed chatter concert.. However, on step 3.3 the launch halts.

EDIT1: similar warnings are received on (successful) launching of local nodes, so I guess that is not the issue
The info (and possible cause of trouble) that I get is:

Rapp Manager : disabling apps requiring capabilities [Couldn't find capability server node. Error: Node 'capability_server' not found.]

Rapp Manager : 'rocon_apps/chirp' is not unique and has no preferred rapp. rocon_apps/moo_chirp' has been selected.

The last received info is about Rapp manager initialised, and what usually follows (in successful, local launches) is the info about adding connection to public interface. Could that be a trouble? How could I inspect it further?
I run it on Ubuntu 14.04, ros indigo, and installed rocon via package manager.

edit retag flag offensive close merge delete

Comments

actually, the behaviour is the same as one that can be seen locally when no concert is launch, but dude is launched. that means that remote machine can't detect existing concerts? what could be possible reasons?

gavran gravatar imagegavran ( 2016-03-14 07:07:46 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-03-15 13:11:18 -0600

gavran gravatar image

The problem was not in the ros or concert, but in the fact that my wireless network had some restrictions on broadcasting. The solution for the problem was to create an ad hoc wireless network (as described here, for example) and then the tutorial worked as described.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-09 07:39:09 -0600

Seen: 56 times

Last updated: Mar 15 '16