Why the amcl can't work normally in a rapp [closed]

asked 2014-04-25 04:09:28 -0600

scopus gravatar image

updated 2014-04-25 04:11:20 -0600

Hi, I created a rapp by following this instruction with amcl_demo. The launch file is as follows:

<launch>  
     <include file="$(find turtlebot_navigation)/launch/amcl_infocenter.launch"/>
     <node pkg="robot_pose_publisher" name="robot_pose_publisher" type="robot_pose_publisher"> 
     <rosparam>  
        is_stamped: true   
        base_frame: base_footprint 
     </rosparam> 
     </node>
</launch>

I used this rapp to replace "nav_demo" in multinav_concert of the big project robotic-in-concert.

I run soft_navbot_client.launch( see mulitnav_concert) in a turtlebot. It always comes out "waiting on transform from base_footpirnt to map to become available before running costmap, tf error.” I think this the reason why topic /softbot/amcl_pose doesn't output any data. By checking the tf view_frames, the tf tree doesn't have map. But the map server work normally.

If I run amcl_infocenter.launch outside a rapp, everything works normally. Does anyone have encounter this problem

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by scopus
close date 2014-05-11 04:05:38

Comments

I would like to suggest to introspect rostopic list and info on central workspace and robot workspace to see more details. Also, you should make sure all the topics are connected properly. Since it starts as rapp, topic namespace get applied and some topics may get unconnected.

jihoonl gravatar imagejihoonl ( 2014-05-06 21:16:32 -0600 )edit

Thank you very much for your suggestion! Thank you !

scopus gravatar imagescopus ( 2014-05-08 15:36:31 -0600 )edit