Ask Your Question
2

Problems launching rocon chatter concert inside of a Docker image

asked 2015-02-24 14:20:08 -0600

jcerruti gravatar image

I am trying to get a simple rocon concert working inside of a Docker instance with my limited knowledge of rocon and avahi.

I started from this Docker image which provides the base ROS installation and got rocon_tutorials from the the apt repos there. I verified I can successfully run basic ROS nodes and configurations. Unfortunately, when trying to run the rocon chatter concert I get some issues which I am having trouble getting past.

The most relevant symptom is that all consoles spawned by the rocon launch show the following error:

[ERROR] [1424808531.546619171]: Zeroconf: failed to create an avahi client.

after which everything else fails.

I have tried several things including running avahi manually inside the docker container, making sure to start the docker container in privileged mode, etc.

Any guidance on how to further tackle the problem, or any general hints on getting the environment right for rocon would be greatly appreciated

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-02-25 19:06:27 -0600

jihoonl gravatar image

It seems like docker does not support avahi-daemon properly. And it causes a problem in zero configuration.

I have proposed a patch to use rocon without zero configuration in https://github.com/robotics-in-concer...

With this patch, you should be able to run chatter concert without zeroconf failure.

edit flag offensive delete link more

Comments

Thank you jihoonl, this lets us run rocon inside Docker. I can confirm it works.

jcerruti gravatar imagejcerruti ( 2015-02-26 08:46:08 -0600 )edit
0

answered 2017-07-03 00:21:49 -0600

Eric_ROS gravatar image

hello~ I create a docker which includes: 1. ROS indigo full installed version 2. turtlebot package

After finishing the network configuration on ~/.bashrc, I run the command roslaunch turtlebot_bringup minimal.launch. and have the same problem [ERROR] [1424808531.546619171]: Zeroconf: failed to create an avahi client.

Can you share some solution to solve this problem? Thank you

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-02-24 14:20:08 -0600

Seen: 453 times

Last updated: Jul 03 '17