Ask Your Question
0

rtabmap_ros loop closure rejection when doing tutorial

asked 2016-02-26 07:52:50 -0600

Azharudeen gravatar image

I am using ros indigo in ubuntu 14.04 when i am running the stereo outdoor tutorial in rtabmap_ros with Stereo_outdoorB.bag file as in :link i get a loop closure rejction error at the end of the bagfile

here I have atached the screenshots : image description

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-29 14:34:01 -0600

matlabbe gravatar image

Hi,

Use the updated demo_stereo_outdoor.launch from 0.10.12, not the one installed by 0.10.10. Just download the launch file, you would not need to rebuild rtabmap from source.

The old launch file is broken because of the new RGBD/OptimizeMaxError parameter. Either set RGBD/OptimizeMaxError to 0 under the rtabmap node or use the launch file above.

cheers

edit flag offensive delete link more

Comments

thanks matlabbe

Azharudeen gravatar imageAzharudeen ( 2016-03-03 22:33:21 -0600 )edit

The loop closure error was solved but now i get this error: updateMapCloud() map id of node X not found as in the picture i have posted

Azharudeen gravatar imageAzharudeen ( 2016-03-03 22:53:14 -0600 )edit

thanks for your suggestion on new version i rebuild the entire package after downloading the new version it worked...... thanks

Azharudeen gravatar imageAzharudeen ( 2016-03-04 05:20:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-26 07:52:50 -0600

Seen: 282 times

Last updated: Feb 29 '16