Ask Your Question
0

Problems with .bashrc

asked 2016-02-24 23:32:56 -0500

Spartan_007 gravatar image

updated 2016-02-24 23:44:27 -0500

I installed ROS INDIGO in my system. For environment set up I did the following

echo "source /opt/ros/indigo/setup.bash" >> ~/.bashrc

after I write

source ~/.bashrc

Now the following shows up in the terminal,

bash: /home/user_name/catkin_ws/devel/setup.bash: No such file or directory
bash: /home/user_name/catkin_ws/devel/setup.bash: No such file or directory
bash: /home/baban/catkin_ws/devel/setup.bash: No such file or directory
bash: /home/user_name/catkin_ws/devel/setup.bash: No such file or directory
bash: /home/user_name/catkin_ws/devel/setup.bash: No such file or directory
bash: /home/baban/catkin_ws/devel/setup.bash: No such file or directory

I would like to know if there is any thing wrong during installation.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-25 12:25:19 -0500

Spartan_007 gravatar image

updated 2016-02-25 12:27:03 -0500

I solved the issue by gedit ~/.bashrc. Then deleted all the source directories except the two recommended below,

source /opt/ros/indigo/setup.bash

source /home/[your username]/[catkin-workspace]/devel/setup.bash
edit flag offensive delete link more
0

answered 2016-02-25 07:11:08 -0500

multiple catkin-workspace bash is defined

cat ~/.bashrc

you should have only two source define:

source /opt/ros/indigo/setup.bash

source /home/[your username]/[catkin-workspace]/devel/setup.bash

edit flag offensive delete link more

Comments

I checked in my system. I have setup.bash only in

source /opt/ros/indigo/setup.bash

and not in the

source /home/[your username]/[catkin-workspace]/devel/setup.bash
Spartan_007 gravatar image Spartan_007  ( 2016-02-25 10:29:20 -0500 )edit

I used ROS before. This time after removing ROS from the system I removed the catkin_ws from

source /home/[your username]/

After re installation of ROS I created catkin_ws using mkdir and catkin_make.

Spartan_007 gravatar image Spartan_007  ( 2016-02-25 10:45:18 -0500 )edit

Then the following are showing:

bash: /home/user_name/catkin_ws/devel/setup.bash: No such file or directory
Spartan_007 gravatar image Spartan_007  ( 2016-02-25 10:46:09 -0500 )edit

There is a setup.bash in /home/user_name/catkin_ws/devel/ I tried to open it using sudo gedit, shows error

(gedit:2542): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Spartan_007 gravatar image Spartan_007  ( 2016-02-25 11:07:29 -0500 )edit
0

answered 2016-02-25 01:46:00 -0500

Akif gravatar image

Is path to your catkin workspace correct? user_name seems just like a place holder.

edit flag offensive delete link more

Comments

I installed the Indigo version as provided in the ROS website. I used it before also. But this time before installation I removed the catkin_ws from the

source /home/[your username]/[catkin-workspace]/devel/setup.bash

Now after installation I created catkin_ws using 'mkdir' and 'catkin_make'.

Spartan_007 gravatar image Spartan_007  ( 2016-02-25 10:39:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-24 23:32:56 -0500

Seen: 2,147 times

Last updated: Feb 25 '16