Ask Your Question
0

bash problems on pr2, robot command not found

asked 2014-09-24 10:42:37 -0500

Fred Eduardo gravatar image

updated 2014-11-22 17:05:50 -0500

ngrennan gravatar image

Hey guys, I was having some issues with the kinect on the pr2 and so I had to uninstall and reinstall openni. I now get the kinect working (roslaunch / ros commands in general work), but somehow I think I messed up the bash configuration on the Pr2 machine. Now all commands robot start/stop, robot users etc, are not found.

I tried source again /opt/ros/groovy/setup.bash but nothing seems to work.

Also, right when I ssh into the pr2 machine AND when I type /bin/bash, I get the following:

-bash: /usr/bin/check-ssh-keys: No such file or directory Sourcing /etc/ros/setup.bash -bash: /etc/ros/setup.bash: No such file or directory

Do you guys know any workaround for this issue?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-09-24 22:45:53 -0500

ahendrix gravatar image

You didn't just mess up bash. It sounds like you uninstalled most of the system management utilities that are required on the PR2. Did the package manager ask you something like:

You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'

(You should never answer yes to that prompt without consulting a PR2 support representative first).

You should be able to get back to mostly working by reinstalling the pr2-core-groovy and pr2-network packages:

sudo apt-get install pr2-core-groovy pr2-network

You should probably follow that up by running a systemcheck to make sure things are functioning properly.

edit flag offensive delete link more
0

answered 2014-10-01 13:19:22 -0500

Fred Eduardo gravatar image

updated 2014-10-03 14:15:40 -0500

Yeah it was my fault. I got everything working with above commands, but now joystick doesn't work:

I have the robot commands now but because of the previous issue, joystick doesn't work and some stuff is missing on diagnostics. for example:

Power system: error
IBPS 0 to 3 are missing, smart battery all missing. the only ok is the power board 1056.
    More examples:
Devices: error
Joystick: Stale
Joysting driver status: missing

I tried to reinstall joystick drivers then, and I got the following:

$ sudo apt-get install ros-groovy-joystick-drivers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ros-groovy-joystick-drivers is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ros-groovy-oculus-sdk : Depends: libudev-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

So I did apt-get -f install and I think it installed livudev-dev and everything.

So I tried installing again the drivers and all went well:

$ sudo apt-get install ros-groovy-joystick-*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'ros-groovy-joystick-drivers' for regex 'ros-groovy-joystick-*'
ros-groovy-joystick-drivers is already the newest version.
The following packages were automatically installed and are no longer required:
  config-package-dev libpcl-surface-1.7-dev
  ros-hydro-opencv2 syslinux dnsmasq-base
  libnet-ssleay-perl ros-hydro-rosbag ros-hydro-cv-bridge
  chrony libgraphicsmagick3 ckermit pr2-grant
  libpcl-surface-1.7 libpcl-features-1.7-dev
  libcxsparse2.2.3 octave3.2 ros-hydro-roscpp
  ros-hydro-rosgraph libfile-copy-recursive-perl
  ros-hydro-image-proc ros-hydro-roscpp-serialization
  ros-hydro-smclib ros-hydro-roslaunch libglpk0 libarpack2
  ros-hydro-rospack libpcl-outofcore-1.7
  libpcl-recognition-1.7 ros-hydro-message-runtime
  pr2-ctr350 libcholmod1.7.1 libxml-parser-perl liburi-perl
  unionfs-fuse ros-hydro-message-filters ros-hydro-roslib
  libpcl-geometry-1.7-dev libhtml-parser-perl
  ros-hydro-rosnode update-inetd
  libpcl-registration-1.7-dev pr2-sendhwlog libv8-3.7.12.22
  libhttp-daemon-perl ros-hydro-rosmsg rlinetd
  ros-hydro-tf2-msgs ros-hydro-rosout
  ros-hydro-camera-info-manager screen ros-hydro-pcl-msgs
  libfont-afm-perl pr2-netconsole libhttp-negotiate-perl
  libfile-listing-perl libhtml-form-perl
  libpcl-features-1.7 libfftw3-3 syslinux-common
  libvtk5.8-qt4 python-urlgrabber bluez-hcidump
  ros-hydro-nodelet ifplugd ros-hydro-roswtf
  ros-hydro-actionlib libaprutil1-ldap apache2-mpm-prefork
  cdbs libpcl-tracking-1.7 netperf
  ros-hydro-camera-calibration-parsers apache2-utils
  ros-hydro-topic-tools libpcl-tracking-1.7-dev
  libccolamd2.7.1 ros-hydro-cpp-common
  libpcl-search-1.7-dev apache2 tcsh libhtml-tree-perl
  ros-hydro-gencpp intltool libencode-locale-perl
  libhttp-date-perl ros-hydro-actionlib-msgs
  libmailtools-perl snmpd ros-hydro-diagnostic-msgs
  pr2-chrony liblwp-protocol-https-perl apache2.2-common
  ros-hydro-rostest libnetfilter-conntrack3 timelimit snmp
  libpcl-keypoints-1.7 pr2-sysros libpcl-apps-1.7
  ros-hydro-tf2-ros ros-hydro-rostime libparpack2
  ros-hydro-rosgraph-msgs libhttp-cookies-perl
  libpcl-keypoints-1.7-dev libhttp-message-perl
  ros-hydro-geometry-msgs python-svn
  ros-hydro-message-generation ros-hydro-rosservice
  smartmontools pr2-ckill python-scour ros-hydro-genmsg
  libaprutil1-dbd-sqlite3 libflann1 ros-hydro-class-loader
  libapache2-mod-python libcolamd2.7.1 ros-hydro-rosclean
  nodejs libnet-http-perl apache2.2-bin ros-hydro-xmlrpcpp
  ros-hydro-rosmaster libgraphicsmagick++3 octave3.2-common
  ros-hydro-rosunit libpcl-octree-1.7-dev libcap-dev
  ros-hydro-genlisp libpcl-people-1.7 nfs-kernel-server
  libhtml-format-perl ros-hydro-image-geometry libev4
  libpcl-common-1.7-dev pr2-wrt610n ros-hydro-catkin
  ros-hydro-rosbag-storage ros-hydro-bondcpp
  libpcl-search-1.7 libpcl-sample-consensus-1.7-dev
  libpcl-common-1.7 ros-hydro-roscpp-traits pr2-repo
  pr2-netboot dnsmasq libdaemon0 libsocket6-perl libc-ares2
  ros-hydro-tf zsh ros-hydro-bond executable-selector
  pr2-stress libpcl-filters-1.7 pr2-repo-pr2
  ros-hydro-image-transport ros-hydro-dynamic-reconfigure
  libpcl-kdtree-1.7-dev dh-translations libhtml-tagset-perl
  libpcl-filters-1.7-dev ros-repo ros-hydro-rospy libkms1
  libwww-perl ros-hydro-nodelet-topic-tools fuse-utils
  libvtk5-qt4-dev ros-hydro-rosbuild ros-hydro-tf2-py
  libflann-dev ros-hydro-rosconsole ros-hydro-std-msgs
  libpcl-registration-1.7 ros-hydro-genpy ros-hydro-tf2
  libio-socket-ssl-perl libqrupdate1 libpcl-1.7-doc distcc
  libpcl-sample-consensus-1.7 libwww-robotrules-perl
  liblwp-mediatypes-perl libpcl-segmentation-1.7
  libpcl-octree-1.7 ros-hydro-rosparam
  ros-hydro-console-bridge ros-hydro-sensor-msgs
  libpcl-kdtree-1.7 ros-hydro-rostopic
  ros-hydro-diagnostic-updater texinfo pr2-systemcheck
  libio-socket-inet6-perl atftpd
  libpcl-segmentation-1.7-dev pr2-bios-bmc-images
  ros-hydro-pluginlib
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 252 not upgraded.

But diagnostic still says joystick is stale and Joystick driver is missing so I cant control the Robot ...

there are some weird ... (more)

edit flag offensive delete link more

Comments

Have you tried running apt-get -f install as it suggests?

ahendrix gravatar image ahendrix  ( 2014-10-01 13:55:03 -0500 )edit

Given that you uninstalled and had to reinstall the joystick drivers, you probably need to restart the ps3joy service: sudo service ps3joy restart

ahendrix gravatar image ahendrix  ( 2014-10-01 13:58:52 -0500 )edit

I tried all above, No work.

I then tried apt-get install --reinstall ros-groovy-joystick-drivers and no work. I tried reinstall pr2-core-groovy and network, stilll no work. i dont what else to do.

Fred Eduardo gravatar image Fred Eduardo  ( 2014-10-03 14:11:27 -0500 )edit

You should probably contact PR2 support.

ahendrix gravatar image ahendrix  ( 2014-10-03 14:30:28 -0500 )edit

Yeah, I just installed pr2-* and ros-groovy-pr2-* and now my diagnosis is all green. Thanks a lot Hendrix!

Fred Eduardo gravatar image Fred Eduardo  ( 2014-10-03 15:28:27 -0500 )edit

That's almost certainly a bad idea, because it pulls in many packages, and may even try to install conflicting packages, or packages that shouldn't be installed on a PR2. It would be much better to look at the set of packages that weren't installed, and only install them if they're necessary.

ahendrix gravatar image ahendrix  ( 2014-10-03 16:28:03 -0500 )edit

This is why I suggest that you contact PR2 support; they understand which packages are necessary and can walk you through the debugging process.

ahendrix gravatar image ahendrix  ( 2014-10-03 16:28:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-24 10:42:37 -0500

Seen: 753 times

Last updated: Oct 03 '14