Ask Your Question
0

[hydro/installation] bash: setup.sh: no such file or directory [closed]

asked 2014-08-01 10:12:04 -0500

Orso gravatar image

I have the following condition: - Ubuntu 12.04 LTS 64 bit - ROS Hydro Uninstalled previous version of Hydro which worked beautifully, then re-installed following the Desktop_Full Install. Everything is fine until I run source ~/.bashrc.

This produces:

bash: /home/daniel/ros/hydro/catkin/devel/setup.bash: No such file or directory
bash: /usr/local/share/gazebo/setup.sh: No such file or directory
bash: /usr/local/share/gazebo/setup.sh: No such file or directory
bash: /usr/local/share/gazebo/setup.sh: No such file or directory
bash: /usr/local/share/gazebo/setup.sh: No such file or directory
bash: /usr/local/share/gazebo/setup.sh: No such file or directory

There is no /home/daniel/ros folder. And, there is no /usr/local/share/gazebo/setup.sh file. Shouldn't these have been automatically generated during install? Thanks for reading this.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Orso
close date 2014-08-06 19:51:21.837879

Comments

Is this a source or apt-get installation?

dornhege gravatar image dornhege  ( 2014-08-01 12:14:01 -0500 )edit

This is an apt-get install ros-hydro-desktop-full installation. Perhaps I faulted something during the uninstall.

Orso gravatar image Orso  ( 2014-08-01 12:43:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-01 12:54:33 -0500

gvdhoorn gravatar image

updated 2014-08-01 12:55:47 -0500

Your previous installation most likely included Gazebo built from source (hence the /usr/local prefix), and you had a directory /home/daniel/ros/hydro/catkin/devel which contained a setup.bash file. These seem to no longer exist.

Either remove the lines from your .bashrc, or update them for the current setup (ie: source /opt/ros/hydro/setup.bash.


Edit: see also Removed Distro btw.

edit flag offensive delete link more

Comments

Thanks for your support. Removed the directories in .bashrc, resulting in a number of other errors. Ended up restoring previous snapshot of Ubuntu. This is my first question post. Seems unanswered as I have given up on the fix. How is this post then closed?

Orso gravatar image Orso  ( 2014-08-06 19:50:16 -0500 )edit

I have no idea who closed your question. As to your problem: it would probably have helped if you had updated your question with what exactly "a number of other errors" are, so we could take a look at those. The symptoms you described are normally solved by avoiding sourcing from your bashrc, so I'm surprised it didn't work for you.

gvdhoorn gravatar image gvdhoorn  ( 2014-08-07 01:40:39 -0500 )edit

Also, how is this question not relevant, or how is it outdated exactly?

gvdhoorn gravatar image gvdhoorn  ( 2014-08-07 01:41:08 -0500 )edit

For future questions I will work through problem, update, repost. After your provided fix I received more errors, I believe stemmed from my erred removal of the previous installation of Gazebo as you suggested. So your fix worked, but resulted in more errors. Closed with outdated as no other option.

Orso gravatar image Orso  ( 2014-08-07 09:51:09 -0500 )edit

Question Tools

Stats

Asked: 2014-08-01 10:12:04 -0500

Seen: 2,745 times

Last updated: Aug 01 '14