rqt Plugins segfault

asked 2016-02-15 08:47:58 -0600

JanB gravatar image

I've tried to make this tutorial about Ros Topic http://wiki.ros.org/ROS/Tutorials/Und... . But if I open rqt_graph it gives me a segmentation fault back. It doesn't matter if I excecute with "rosrun rqt_graph rqt_graph" or with just "rqt_graph" in my terminal. I would like to give you some debugging information but there aren't any other information than SegFault.

I am using Ubuntu 15.04 and Ros Jade

edit retag flag offensive close merge delete

Comments

You can probably at least get a working rqt_gui again by removing the $HOME/.config/ros.org/rqt_gui.ini file if it's there (or rename/move it to some other location). This will reset your current configuration, but sometimes it gets corrupted.

gvdhoorn gravatar image gvdhoorn  ( 2016-02-15 09:57:22 -0600 )edit

The rqt gui itself is working but if I click in the gui in the plugin section to open the graph plugin everything is falling apart.

To reset my configs didn't work.

JanB gravatar image JanB  ( 2016-02-15 10:21:07 -0600 )edit

Ok, sounds like a more serious issue then with rqt_graph. Would be nice if you can report it on the issue tracker. Include all relevant information. Also try to get a GDB backtrace of the segfault.

gvdhoorn gravatar image gvdhoorn  ( 2016-02-15 10:43:05 -0600 )edit

I'm assuming you installed everything using apt-get?

gvdhoorn gravatar image gvdhoorn  ( 2016-02-15 10:44:31 -0600 )edit

That's right.

JanB gravatar image JanB  ( 2016-02-19 01:24:20 -0600 )edit

Did you solve your issue?

emersonjr gravatar image emersonjr  ( 2016-11-14 15:08:14 -0600 )edit

Seems related to this question

damjan gravatar image damjan  ( 2017-04-11 15:09:19 -0600 )edit