Ask Your Question
0

How can Local_planner handle a Lidar blind spot.

asked 2016-02-10 17:00:32 -0500

trips323 gravatar image

updated 2016-02-10 18:35:22 -0500

The lidar on my robot is on the front of the robot so the robot creates a blind spot behind the lidar. How can i get objects to not disappear on the local costmap when they go into the blind spot?

The lidar is reporting "inf" values in the blind spot.

I have track_unknown_space: true for the local_costmap

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-02-16 04:06:23 -0500

Procópio gravatar image

updated 2016-02-18 09:51:01 -0500

you can try to set the parameter inf_is_valid: false . in this way the local costmap (or global) will not treat scans with "inf" values.

this is a quick fix, and you may have problems with not clearing the costmaps in front of the robot if your sensor outputs "inf" for scans farther than max_range, for example. in that case you might want to use a filter to correct that kind of measurements from your data as in here.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-10 17:00:32 -0500

Seen: 270 times

Last updated: Feb 18 '16