Ask Your Question
0

OpenNI2Driver, No matching device found

asked 2016-02-10 11:01:21 -0600

arttp2 gravatar image

updated 2016-02-19 01:34:23 -0600

EDIT 3:

The issue returns if the package is launched in superuser mode.


Hello all,

I have just installed ROS Indigo on my turtlebot PC having Ubuntu 14.04.02 which was just upgraded from Ubuntu 12. Earlier the turtlebot PC had Hydro. The problem I am describing hence was not present in the hydro installation.

On running,

roslaunch openni2_launch openni2.launch ,

I am getting the following error:

[ INFO] [1455122966.352999612]: Initializing nodelet with 4 worker threads.
[ INFO] [1455122968.132593659]: No matching device found.... waiting for devices. Reason: std::string openni2_wrapper::OpenNI2Driver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-indigo-openni2-camera-0.2.5/src/openni2_driver.cpp @ 631 : Invalid device number 1, there are 0 devices connected.

I have tried the following solutions:

roslaunch freenect_launch freenect.launch : Does not work

https://github.com/turtlebot/turtlebo... : Does not work

I also tried installing all sorts of drivers for the Kinect on turtlebot. The kinect works on other software giving me RGB as well as Depth sensing but still gmapping or any node requiring Kinect is ROS does not work probably because ROS Indigo uses OpenNi2 and not the driver I tested my kinect.

Thanks for the read.

EDIT_1:

I just got hold of this page regarding migration of turtlebot from Hydro to Indigo

http://wiki.ros.org/Robots/TurtleBot/...

Though I have set up the environment variable export TURTLEBOT_3D_SENSOR=kinect in my ~/.bashrc file, I do not know how to update to the new driver and get any calls from the existing ROS packages like gmapping to stop looking for OpenNI2.

EDIT_2:

Should I do a source install because the deb install is still calling OpenNi2 drivers instead of Freenect for Kinect?

Is there a way to substitute OpenNI2 drivers with freenect, or any working driver in turtlebot_navigation package.

edit retag flag offensive close merge delete

Comments

1

Are you trying to use rgbdslam on the turtlebot? Does freenect-regview work for you? You can download it with sudo apt-get install libfreenect-lib

jacksonkr_ gravatar imagejacksonkr_ ( 2016-02-11 07:31:03 -0600 )edit

I had already installed using sudo apt-get install freenect and the above command gives the output Unable to locate package libfreenect-lib. I tried to launch roslaunch turtlebot_navigation gmapping_demo.launch and this calls OpenNI2 not freenect, hence installing it did not help.

arttp2 gravatar imagearttp2 ( 2016-02-11 08:57:04 -0600 )edit
1

Have you tried this: sudo apt-get install --reinstall ros-indigo-openni-camera ros-indigo-openni-launch ?

Orhan gravatar imageOrhan ( 2016-02-11 09:05:28 -0600 )edit

Reinstalling drivers helped. It does not show the OpenNI driver error now. But it shows some other warnings and errors that also came up when I was testing with the freenect. Nevertheless, gmapping works fine as seen in rviz. Thanks for the answer.

arttp2 gravatar imagearttp2 ( 2016-02-11 09:50:10 -0600 )edit

You should ask a new Question for your update.

Orhan gravatar imageOrhan ( 2016-02-19 01:55:29 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-11 11:15:51 -0600

Orhan gravatar image

updated 2018-11-19 05:19:01 -0600

Try;

sudo apt-get install --reinstall ros-indigo-openni-camera ros-indigo-openni-launch

edit flag offensive delete link more

Comments

1

Thank you!

arttp2 gravatar imagearttp2 ( 2016-02-11 11:36:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-10 11:01:21 -0600

Seen: 7,287 times

Last updated: Nov 19 '18