Ask Your Question
0

nav2d StartExploration finished without doing anything

asked 2015-10-20 04:32:36 -0500

Swan Baigne gravatar image

updated 2015-10-22 04:33:30 -0500

Hello, I am currently trying to use nav2d service : StartExploration to make my turtlebot robot map a unknown room with Ubuntu 14.04 and ROS Indigo.

When i use the service StartMapping to get the first map, the robot does move ahead and turn on itself to create the map. After that, when i launch the StartExploration service, it only say that "exploration has finished" without mapping the room.

Here is the rqt_console list of debug message for StartExploration : http://hpics.li/a24def6

I though it was a problem with the inflation radius, but after lowering the parameter in navigator.yaml and costmap.yaml the result stay the same.

Here is the map viewed by Rviz : http://hpics.li/537b9fc

Any hint on what topic i should look at to know where the problem is ?? i looked at Explore/goal, and a goal is indeed created each time i start the service, but the goal part of the message is blank.

EDIT : map au format pgm : http://s000.tinyupload.com/?file_id=7... map au format yaml : http://s000.tinyupload.com/?file_id=5...

edit retag flag offensive close merge delete

Comments

So has there been any answer to this issue, because I am facing the same problem

mengeler gravatar imagemengeler ( 2017-01-30 07:25:11 -0500 )edit

@mengeler Please only use answers to provide answers to questions. I've moved your answer to be a comment.

jarvisschultz gravatar imagejarvisschultz ( 2017-01-30 07:34:04 -0500 )edit

If you get "Exploration has finished.", open the map in RVIZ and check if there are reachable frontier cells. If you think there is at least one, set it manually as a goal point and see if the robot can go there. The problem is usually a too large robot_radius in the navigator.

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2017-02-01 08:39:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-21 06:30:03 -0500

Sebastian Kasperski gravatar image

"Exploration has finished" means that there is no reachable frontier cell from the robot's position anymore. So with the inflation radius your already on the right track. But looking at your map it seems that your global map resolution is very low. This might also be a problem, as there must be at least 1 pixel left free after applying the inflation radius to all obstacles. So try increasing the map resolution and test the navigator by sending goal points in RVIZ.

edit flag offensive delete link more

Comments

I forgot to mention it on the question, but i was able to create the map correctly by using RVIZ to send goal. I will test changing the map resolution and post here the results. Once again , thanks for answering

Swan Baigne gravatar imageSwan Baigne ( 2015-10-21 07:53:04 -0500 )edit

Changed the grid_resolution parameter in mapper.yaml to 0.025, and the map is much clearer that before. But the exploration is still finished as soon as it begin, despite having clear boundary open.

Swan Baigne gravatar imageSwan Baigne ( 2015-10-21 08:58:01 -0500 )edit

Have you tried moving the robot manually with the joystick? (Using the joy_node->remote_controller->operator->robot chain) If your doors are too narrow for the used robot_radius, the planner will also not plan through them and therefor finish the exploration.

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2015-10-21 10:04:37 -0500 )edit

i have tried to move the robot with simulated joystick ( turtlebot keyboard_teleop ), and i have no problem. I tried to reduce the robot_radius and inflation radius to minimum ( 0.01 ), and the exploration still finish instantly, so i think the problem don't come from not having enough free pixel.

Swan Baigne gravatar imageSwan Baigne ( 2015-10-22 02:40:41 -0500 )edit

Have you tried the navigation by setting a goal manually in RVIZ? And set the log-level to debug for the Navigator, if you haven't done so.

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2015-10-22 02:59:00 -0500 )edit

for RVIZ yes, it works well with manually chosen goals. And for the log level, i have this debug log when i try to launch the exploration :http://hpics.li/a24def6

Swan Baigne gravatar imageSwan Baigne ( 2015-10-22 03:36:26 -0500 )edit

That is strange... Can you send your global map again after the exploration finished. (You can save the map with "rosrun map_server map_saver", or make a screen in RVIZ without the local costmap.)

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2015-10-22 04:04:14 -0500 )edit

added both maps (pgm and yaml ) to the initial question

Swan Baigne gravatar imageSwan Baigne ( 2015-10-22 04:33:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-20 04:32:36 -0500

Seen: 396 times

Last updated: Jan 30 '17