Ask Your Question
0

Can't install kobuki

asked 2015-12-26 15:47:24 -0500

nampi gravatar image

I go through this tutorial. In 2.3.2 I run this command:

wstool init src -j5 https://raw.github.com/yujinrobot/yujin_tools/master/rosinstalls/indigo/kobuki.rosinstall

I have an error:

fatal: unable to access 'https://github.com/yujinrobot/yocs_msgs.git/': gnutls_handshake() failed: A TLS packet with unexpected length was received.
Exception caught during install: Error processing 'yocs_msgs' : [yocs_msgs] Checkout of https://github.com/yujinrobot/yocs_msgs.git version indigo into /home/nadya/kobuki/src/yocs_msgs failed.

ERROR in config: Error processing 'yocs_msgs' : [yocs_msgs] Checkout of https://github.com/yujinrobot/yocs_msgs.git version indigo into /home/nadya/kobuki/src/yocs_msgs failed.

How can I solve this problem?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-12-30 11:38:48 -0500

tfoote gravatar image

This looks like a problem with github's service. I suspect that if you try again it will work.

edit flag offensive delete link more
0

answered 2016-11-30 21:08:36 -0500

Eric_ROS gravatar image

updated 2016-11-30 21:11:05 -0500

Hello~tfoote Now I installed Ubuntu 16.04 and ROS-kinetic on Nvidia TX1 successfully. I tried to install turtlebot packages on it and type:

wstool init src https://raw.githubusercontent.com/turtle bot/turtlebot/kinetic/turtlebot.rosinstall -j8

=====================================================================

Exception caught during install: Error processing 'yocs_msgs' : [yocs_msgs] Checkout of https://github.com/yujinrobot/yocs_ms... version indigo into /home/ubuntu/program_files/nvidia/tx1/install/8_turtlebot_packages/kinect/turtlebot/turtlebot/src/yocs_msgs failed.

ERROR in config: Error processing 'yocs_msgs' : [yocs_msgs] Checkout of https://github.com/yujinrobot/yocs_ms... version indigo into /home/ubuntu/program_files/nvidia/tx1/install/8_turtlebot_packages/kinect/turtlebot/turtlebot/src/yocs_msgs failed.

=====================================================================

I tried it again, but the error is still occurred.

Before doing this, I tried to do turtlebot source installation as 1.3 steps: http://wiki.ros.org/turtlebot/Tutoria...

Some errors shows while installing Kobuki... The reason seems my gazebo is v7(too new???) which has diff function name to support kobuki's build.

Not sure how to do for next, need your suggestion and command. Thank you!! :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-26 15:47:24 -0500

Seen: 546 times

Last updated: Nov 30 '16