Ask Your Question
0

Can't Install kobuki package on the Raspberry Pi 2 model B

asked 2016-12-12 21:37:19 -0500

NKCT gravatar image

I've installed ros on the Raspberry Pi 2 model B following this tutorial.Then, I'm installing kobuki following this tutorial .But I can't install kobuki package.

I execute command "$ sudo apt-get install ros-indigo-kobuki ros-indigo-kobuki-core". Then I get a following error message.

pi@raspberrypi:~ $ sudo apt-get install ros-indigo-kobuki ros-indigo-kobuki-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-kobuki : Depends: ros-indigo-kobuki-auto-docking but it is not going to be installed
                     Depends: ros-indigo-kobuki-bumper2pc but it is not going to be installed
                     Depends: ros-indigo-kobuki-capabilities but it is not going to be installed
                     Depends: ros-indigo-kobuki-controller-tutorial but it is not going to be installed
                     Depends: ros-indigo-kobuki-description but it is not going to be installed
                     Depends: ros-indigo-kobuki-keyop but it is not going to be installed
                     Depends: ros-indigo-kobuki-node but it is not going to be installed
                     Depends: ros-indigo-kobuki-random-walker but it is not going to be installed
                     Depends: ros-indigo-kobuki-rapps but it is not going to be installed
                     Depends: ros-indigo-kobuki-safety-controller but it is not going to be installed
                     Depends: ros-indigo-kobuki-testsuite but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have no idea how I can solve the error. Can you please give me information on that?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-03 02:35:20 -0500

MarkyMark2012 gravatar image

You will need to compile the Kobkui source from scratch. There isn't a precompiled binary

Mark

edit flag offensive delete link more

Comments

Thank you very much for your advise.I succeeded in installing kobuki package!

NKCT gravatar imageNKCT ( 2017-02-07 00:20:27 -0500 )edit

@NKCT - cool. Please let me know if you get the auto docking working. For me is mobile node is crashing (Can you make the answer as right :) )

MarkyMark2012 gravatar imageMarkyMark2012 ( 2017-02-07 05:40:27 -0500 )edit

Sorry. I don't have docking station. So I can't try auto docking working and I have no idea that help you.

NKCT gravatar imageNKCT ( 2017-02-08 18:00:27 -0500 )edit

No worries

MarkyMark2012 gravatar imageMarkyMark2012 ( 2017-02-10 03:21:12 -0500 )edit

Hey, @NKCT I'm also trying to install kobuki packages on Rpi can you elaborate how you succeeded in doing the same?

H.Ruthrash gravatar imageH.Ruthrash ( 2017-05-25 04:44:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-12-12 21:37:19 -0500

Seen: 113 times

Last updated: Feb 03 '17