Ask Your Question
0

Kobuki : Timed out while waiting for serial data stream [/mobile_base] on Indigo

asked 2015-04-13 20:41:38 -0600

MichaelGregg gravatar image

Using a turtlebot 2 on 14.04.2

I ran through the install section at http://wiki.ros.org/turtlebot/Tutoria... and the network setup.

When running:

roslaunch turtlebot_bringup minimal.launch

The kobuki base makes it's startup noise, then, a few seconds later it makes it's shutdown noise. With the following error message being produced on the console:

I get the same error when I try the kobuki node by itself:

$ roslaunch kobuki_node minimal.launch

setting /run_id to 0d2810f0-e247-11e4-8a15-0024d76aae74 process[rosout-1]: started with pid [22493] started core service [/rosout] process[mobile_base_nodelet_manager-2]: started with pid [22510] process[mobile_base-3]: started with pid [22511] process[diagnostic_aggregator-4]: started with pid [22546] This turtlebot was previously working in Furte.

Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-13 22:17:21 -0600

MichaelGregg gravatar image

In the end, powering off, then powering back on my turtlebot laptop seemed to be the fix.

The suspicion was usb bus issues with the kinect and the kobuki on the same usb port.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-13 20:41:38 -0600

Seen: 969 times

Last updated: Apr 13 '15