Ask Your Question
0

When I run "rosrun rviz rviz"after run"roscore",I got this"Segmentation fault (core dump)",and I try to run "gdb -ex run /opt/ros/indigo/lib/rviz/rviz",and then I got a lot of things like this

asked 2015-12-22 02:07:32 -0600

xuminzero gravatar image

updated 2015-12-22 02:40:33 -0600

gvdhoorn gravatar image
ImportError:No module named 'libstdcxx' 
[Thread debugging using libthread_db enabled] 
using host libthread_db library "/lib/arm-linux-gnueabinf/libthread_db.so.1".
Cannot access memory at address 0x0

Program received signal SIGILL,Illegal instruction.
0x74dfa208 in ?? () from /lib/arm-linux-gnueabihf/libcrypto.so.1.0.0
(gdb)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-12-24 00:10:11 -0600

dchang0 gravatar image

I just went through this exact error on an ODROID C1+ (armhf architecture) and immediately got help from the ROS devs.

The bug is here, and the fix is easy--just download and install the latest libpcre3 package (8.35 or higher).

https://github.com/ros/robot_model/is...

edit flag offensive delete link more

Comments

I installed ros-indigo on raspberry pi. Is the error related to this?

xuminzero gravatar imagexuminzero ( 2015-12-27 06:44:37 -0600 )edit

Yes, both the ODROID C1+ and Raspberry Pi use ARM processors, so the ROS software packages would be the same for both.

dchang0 gravatar imagedchang0 ( 2015-12-29 19:58:52 -0600 )edit

Thank you. I have changed the ros-indigo-ros-base to the ros-indigo-desktop and now I can use the rviz.

xuminzero gravatar imagexuminzero ( 2015-12-30 08:01:01 -0600 )edit

@xuminzero could you tell me ho to fix it on raspberry pi 2?

YingHua gravatar imageYingHua ( 2016-01-10 03:57:29 -0600 )edit

you can use the ros-indigo-desktop,maybe it will be solved.

xuminzero gravatar imagexuminzero ( 2016-01-21 02:42:13 -0600 )edit

@xuminzero do you mean reinstall ROS on raspberry pi 2?

YingHua gravatar imageYingHua ( 2016-01-21 03:26:17 -0600 )edit

yeah,I am using this version,and I can use the rviz

xuminzero gravatar imagexuminzero ( 2016-01-21 06:39:44 -0600 )edit
0

answered 2015-12-23 05:19:55 -0600

solosito gravatar image

updated 2015-12-23 05:20:52 -0600

What ROS version are you using? What processor do you have? In case of having an ARM you have to install this ROS version:

http://wiki.ros.org/indigo/Installation/UbuntuARM

Have you tried just running "rviz"?

edit flag offensive delete link more

Comments

I am using ros-indigo, and I installed ros-indigo on raspberry, I don't know there is any relationship with this

xuminzero gravatar imagexuminzero ( 2015-12-27 06:34:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-22 02:07:32 -0600

Seen: 365 times

Last updated: Dec 23 '15