Ask Your Question
0

camera_calibration - override enough data check

asked 2015-12-11 13:52:54 -0500

updated 2015-12-11 14:01:50 -0500

Hi everybody,

I'd like to calibrate a stereo rig with the camera_calibration stereo node. I have a set of pre-recorded images that I publish using a simple ad-hoc player node and with some datasets it works pretty well. I followed stereo tutorial and if the number of images in my sequence is enough no problem arises. The problem is when I do not have enough frames and the calibrate button never lights.

Do you know how I can override the good enough check?

Thank you, Augusto

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-12-13 14:07:53 -0500

lucasw gravatar image

It looks like there is a magic number of 40:

self.goodenough = (len(self.db) >= 40) or all([p == 1.0 for p in progress])

https://github.com/ros-perception/ima...

Change it to zero or whatever you like (clone the the image_pipeline pipeline into your catkin_ws and catkin_make it, if devel or install is sourced it should take precedence over the unmodified image_pipeline elsewhere on your system when you rosrun/launch it).

You could also probably fake it by send the same images repeatedly until 40 is reached.

edit flag offensive delete link more

Comments

Thanks, it works like a charm ;-)

Augusto Luis Ballardini gravatar imageAugusto Luis Ballardini ( 2015-12-14 04:25:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-12-11 13:52:54 -0500

Seen: 68 times

Last updated: Dec 13 '15