Ask Your Question
0

camera1394 and bumblebee2

asked 2011-02-27 08:13:04 -0600

rob-bot gravatar image

updated 2011-02-27 14:10:25 -0600

Hello everyone. I am new to ROS and am currently working on getting the Bumblebee2 node (By Soonhac Hong, source: http://cu-ros-pkg.googlecode.com/svn/... ) to work properly in Ubuntu 10.10 for my Pt grey Bumblebee2 stereo camera.

After resolving some preliminary issues, I continue to receive the same error message whenever I launch Bumblebee2.launch:

"

FATAL 1298844152.453260264: [camera] exception opening device: [Camera1394::open]: No cameras found

"

The node appears in rxgraph.

So I thought to myself "maybe the camera1394 node will work properly?" (I have no experience with this node, so that's just a wild guess) and a tried launching camera.launch from the test folder. I received the following messages:

"

ERROR 1298842394.512674033: [camera] device open failed: [Camera1394::open]: No cameras found ERROR 1298842394.512964522: Unable to open camera calibration file [/cameras/unibrain_calibration.yaml]

"

I also tried launching stereo_example.launch:

" error loading <rosparam> tag:

file does not exist [/cameras/unibrain.yaml]

XML is rosparam file="/cameras/unibrain.yaml"/ "

I have attempted to use the camera using coriander and kino... they both cannot find a camera connected to the bus. I have already troubleshooted common bus permissions issues as per http://www.ros.org/wiki/camera1394/Tr... . The camera works in a Windows environment.

Any ideas how I can get this thing working???

Thanks for the help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-02-28 12:30:45 -0600

joq gravatar image

This is an Ubuntu problem, not a ROS problem, until you solve the bus access problem. No ROS driver is going to work if coriander cannot find the device.

The camera1394 driver does not support Bumblebee or any other interlaced stereo devices. Perhaps it will in some future release (see enhancement ticket #4782).

Note that all the launch files in the camera1394 package tests directory are marked "this is a test script: NOT FOR GENERAL USE". You can construct your own launch files based on those examples, but should not expect them to work unmodified.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-27 08:13:04 -0600

Seen: 1,609 times

Last updated: Feb 28 '11