Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

camera1394 and bumblebee2

Hello everyone. I am new to ROS and am currently working on getting the Bumblebee2 node (By Soonhac Hong, source: http://cu-ros-pkg.googlecode.com/svn/trunk/bumblebee2) to work properly in Ubuntu 10.10 for my Pt grey Bumblebee2 stereo camera.

After resolving some preliminary issues, I continue to receive the same error message whenever I launch Bumblebee2.launch:

" "

The node appears in rxgraph.

So I thought to myself "maybe the camera1394 node will work properly?" (I have no experience with this node, so that's just a wild guess) and a tried launching camera.launch from the test folder. I received the following messages:

" "

I also tried launching stereo_example.launch:

" error loading <rosparam> tag:

file does not exist [/cameras/unibrain.yaml]

XML is rosparam file="/cameras/unibrain.yaml"/ "

I have attempted to use the camera using coriander and kino... they both cannot find a camera connected to the bus. I have already troubleshooted common bus permissions issues as per http://www.ros.org/wiki/camera1394/Troubleshooting#No_Bus_Access_Permissions. The camera works in a Windows environment.

Any ideas how I can get this thing working???

Thanks for the help!

camera1394 and bumblebee2

Hello everyone. I am new to ROS and am currently working on getting the Bumblebee2 node (By Soonhac Hong, source: http://cu-ros-pkg.googlecode.com/svn/trunk/bumblebee2) to work properly in Ubuntu 10.10 for my Pt grey Bumblebee2 stereo camera.

After resolving some preliminary issues, I continue to receive the same error message whenever I launch Bumblebee2.launch:

" "

"

The node appears in rxgraph.

So I thought to myself "maybe the camera1394 node will work properly?" (I have no experience with this node, so that's just a wild guess) and a tried launching camera.launch from the test folder. I received the following messages:

" "

"

I also tried launching stereo_example.launch:

" error loading <rosparam> tag:

file does not exist [/cameras/unibrain.yaml]

XML is rosparam file="/cameras/unibrain.yaml"/ "

I have attempted to use the camera using coriander and kino... they both cannot find a camera connected to the bus. I have already troubleshooted common bus permissions issues as per http://www.ros.org/wiki/camera1394/Troubleshooting#No_Bus_Access_Permissions. The camera works in a Windows environment.

Any ideas how I can get this thing working???

Thanks for the help!

camera1394 and bumblebee2

Hello everyone. I am new to ROS and am currently working on getting the Bumblebee2 node (By Soonhac Hong, source: http://cu-ros-pkg.googlecode.com/svn/trunk/bumblebee2) to work properly in Ubuntu 10.10 for my Pt grey Bumblebee2 stereo camera.

After resolving some preliminary issues, I continue to receive the same error message whenever I launch Bumblebee2.launch:

"

FATAL 1298844152.453260264: [camera] exception opening device: [Camera1394::open]: No cameras found

"

The node appears in rxgraph.

So I thought to myself "maybe the camera1394 node will work properly?" (I have no experience with this node, so that's just a wild guess) and a tried launching camera.launch from the test folder. I received the following messages:

"

ERROR 1298842394.512674033: [camera] device open failed: [Camera1394::open]: No cameras found ERROR 1298842394.512964522: Unable to open camera calibration file [/cameras/unibrain_calibration.yaml]

"

I also tried launching stereo_example.launch:

" error loading <rosparam> tag:

file does not exist [/cameras/unibrain.yaml]

XML is rosparam file="/cameras/unibrain.yaml"/ "

I have attempted to use the camera using coriander and kino... they both cannot find a camera connected to the bus. I have already troubleshooted common bus permissions issues as per http://www.ros.org/wiki/camera1394/Troubleshooting#No_Bus_Access_Permissions. The camera works in a Windows environment.

Any ideas how I can get this thing working???

Thanks for the help!