ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

catkin_make, CMake Error on Raspberry Pi 2

asked 2015-12-11 02:57:33 -0500

owenqyzhang gravatar image

I followed the instructions in the link down below to install ROS Jade on a Raspberry Pi 2 running ubuntu 14.04.3 LTS link text However, after setting up a catkin workspace and tried to run catkin_make, I got the following messages

CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

The problem is, I already have cmake installed, when I run cmake --version, I got

cmake version

Any idea how to solve the problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-03 02:01:40 -0500

KCL gravatar image

I encountered the same problem but solved it when I ran the following command.

sudo apt-get install build-essential -y

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-12-11 02:57:33 -0500

Seen: 355 times

Last updated: Dec 11 '15