Debugging issues in a catkin build (of SimTrack) [closed]

asked 2016-01-19 13:44:17 -0600

physincubus gravatar image

I have run into an interesting problem. There is a library for real-time, robust visual tracking of objects using GPU called SimTrack, which on the majority of my machines builds. However, on one of my machines (unfortunately, the once purpose-built to handle this sort of computational load), the built Simtrack system seemed to suddenly stop working correctly. Thinking that this is weird, I tried to rebuild the catkin workspace, which unexpectedly failed on a few ambiguous vector and string declarations in the code (specifically at _________).

To attempt to revert back to where this code built, I ran catkin _make clean on my catkin workspace, and even for good measure deleted the build, devel, and install folders, and the source folder for SimTrack (but not before copying them), and used wstool update to pull down the master from github, which I know built before, and still builds on the system from which I am writing this now. However, no matter the changes I make to the workspace, I cannot zero in on the problem breaking this build. I managed to get it to build by changing the offending vector and string calls to std::vector and std::string, but not only do i think this should be unnecessary because:

  1. the unchanged code builds on other machines
  2. the edited code does not run properly

I think the issue has something to do with the way catkin_make is trying to build the code, i.e. CMake parameters, etc., but I am a bit new to this, so any help or suggestions for how to diagnose this problem are appreciated.

Machine 1 (not working, was working originally): Ubuntu 14.04.3 ROS Indigo CUDA 7.5

Machine 2 (working) Ubuntu 12.04.2 ROS Groovy CUDA 6.5

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-02-15 20:43:35.676508

Comments

please add the full error output of the build. Otherwise it is impossible to help.

However, one big difference between your working and not working machines is the different OS and ROS versions. So this might definitely affect the outcome. Do you have a machine with similiar to 1 where this works?

mgruhler gravatar image mgruhler  ( 2016-01-26 07:27:35 -0600 )edit